
  





















<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.idahopress.com/content/tncms/live/" />
<meta name="tncms-access-criteria" content="{&quot;b7276ffc-a7a2-11eb-ae08-bbce9855d1f9&quot;:[]}" />
<meta name="tncms-criteria-ids" content="" />
<meta name="tncms-access-version" content="2021-05-07 15:09:55" />
<meta name="tncms-access-asset-app" content="editorial" />
<meta name="tncms-access-asset-id" content="83b21706-0a2a-5f94-bada-38346fdbe167" />
<meta name="keywords" content="ticket, open market, farmhouse collective, food, commerce, economics, internet, auction, jurassic, vendor" />
<meta name="news_keywords" content="ticket, open market, farmhouse collective, food, commerce, economics, internet, auction, jurassic, vendor" />
<meta name="description" content="Visit the Farmhouse Collective&rsquo;s Summer Open Market June 4-5" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=0, shrink-to-fit=no" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=501121541" />
<meta name="google-play-app" content="app-id=com.idahopress.android" />
<meta name="googlebot" content="noarchive" />
<meta name="google-site-verification" content="wqsuraTJBaQlohvgtIInvOQuZSn9xBbFYtr2miWsnTU" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/1/0d/10dba617-7a84-5368-a795-8e92ccdd44cd/5f35de544a5db.image.jpg?crop=1090%2C1090%2C95%2C0&amp;resize=630%2C630&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="630" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Things To Do" />
<meta property="og:description" content="Visit the Farmhouse Collective&rsquo;s Summer Open Market June 4-5" />
<meta property="og:site_name" content="Idaho Press" />
<meta property="og:section" content="Idaho Press" />
<meta property="fb:app_id" content="2959550254137794" />
<meta property="article:publisher" content="http://www.facebook.com/Idaho.Press.Tribune" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@theidahopress" />
<meta name="twitter:image:alt" content="English garden" />
<meta property="fb:pages" content="101360505199" />
<meta property="tncms:ads" content="smart" />
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/png_core/resources/styles/png.css?_dc=1608190954"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.b52c9bbd5b1d27051cfbfcc0c180c246.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.da34fee69fbd9a506f70c74c56e2ccfa.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/global/resources/styles/site.css?_dc=1585690676"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,400i,700,700i|Raleway:700,700i,900,900i"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/styles/site.css?_dc=1610482134"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-designer.59905c960650c756bd917d9e081675c9.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<style>/*<![CDATA[*/ #user-controls-1506245 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1506245 .tn-user-screenname, #user-controls-1506245 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1506245 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1506245 .dropdown-signup { font-size: 12px; } #user-controls-1506245 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1506245 .large-user-avatar { margin-right: 10px; } #user-controls-1506245 .large-user-controls { font-size: 12px; } #user-controls-1506245 .logout-btn { cursor: pointer; } #user-controls-1506245 .user-welcome { color: #ffffff; } #user-controls-1506245 .login-btn { color: #fff!important; } #block-1268830 .search-spinner { position: absolute; } #block-1268830 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1268830 { margin-bottom: 0; } #site-search-1268830 .site-search-form { padding: 0; } #site-search-1268830 #site-search-1268830-btn { outline: none; } #site-search-1268830 #site-search-1268830-term { border: 0; box-shadow: none; } #site-search-1268830 .site-search-form { box-shadow: none; } #weather-1580754 .list-unstyled { margin: 0; } #weather-1580754 span { display: block; } #weather-1580754 .forecast-link a { padding: 8px; margin-top: -10px; } #weather-1580754 .icon { position: relative; } #weather-1580754 .icon .tnt-svg { position: relative; font-size: 52px; margin-right: 5px; margin-top: -8px; } #weather-1580754 .temp { font-size: 24px; line-height: 24px; margin-top: 4px; font-weight: bold; } #weather-1580754 .cond { opacity: 0.7; } #weather-1580754 .current-conditions { float: left; height: 48px; } #weather-1580754 .dropdown-toggle { color: #ffffff; display: block; } #weather-1580754.inverted .dropdown-toggle { color: #333; display: block; } #block-1506238 .search-spinner { position: absolute; } #block-1506238 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1506238-dropdown .dropdown-menu { padding: 15px; width: 400px; font-weight: normal; } @media screen and (max-width: 991px) { #site-search-1506238-dropdown .dropdown-toggle { display: none; } #main-navigation .navbar-left { clear: both; } #site-search-1506238-dropdown .pull-right { float: none!important; } #site-search-1506238-dropdown .dropdown-menu { display: block; position: static; float: none; width: auto; margin-top: 0; background-color: transparent; border: 0; box-shadow: none; border-radius: 0; border-bottom: 1px solid rgba(0,0,0,0.1); } } #user-controls-1506241 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1506241 .tn-user-screenname, #user-controls-1506241 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1506241 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1506241 .dropdown-signup { font-size: 12px; } #user-controls-1506241 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1506241 .large-user-avatar { margin-right: 10px; } #user-controls-1506241 .large-user-controls { font-size: 12px; } #user-controls-1506241 .logout-btn { cursor: pointer; } #user-controls-1506241 .user-welcome { color: #ffffff; } #user-controls-1506241 .login-btn { color: #fff!important; } #ad-1503253 { min-height: 1px; min-width: 1px; } #block-1830313 .card-panel { border: 5px solid; } #block-1830313 .panel { box-shadow: 10px 10px 10px -10px rgba(0,0,0,0.2); } #block-1830313 .card-panel { border-color: #ccc; } #block-1830313 .promo-designer { background-repeat: no-repeat; background-size: cover; } #block-1830313 .card-panel.panel { background-repeat: no-repeat; background-size: cover; background-position: center; }#block-1830313 .promo-designer, #block-1830313 .card-panel.panel { background-image: url(https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/e65983d6-7077-11ea-b995-0f38095ab884.jpg) } #block-1830313.block { margin-bottom: 0 !important; } #ad-1469104 { min-height: 90px; min-width: 728px; } #ad-1469104 { min-height: 50px; min-width: 320px; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.57.3"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"pattern","style":"default","path":"\/townnews\/commerce","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"infinity_scroll":{"display":"summary","order":"latest"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":212},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"83b21706-0a2a-5f94-bada-38346fdbe167","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.57.3"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"pattern","style":"default","path":"\/townnews\/commerce","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"infinity_scroll":{"display":"summary","order":"latest"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":212},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"83b21706-0a2a-5f94-bada-38346fdbe167","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PZ22872');})();</script>
<script src="https://tags.crwdcntrl.net/c/9940/cc.js?ns=_cc9940" id="LOTCC_9940"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc9940.add('tp', 'TNNW');
		_cc9940.add('act', ' User Login');
		_cc9940.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc9940.bcp();
</script>

<script async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script>/*<![CDATA[*/ window.TNCMS = window.TNCMS || {};window.TNCMS.Access = window.TNCMS.Access || [];(function (callback) { var oScript; var oStorage; try { oStorage = JSON.parse(sessionStorage.getItem('tncms.dmp.audiences')); if (!oStorage || !oStorage.audiences || !oStorage.expired) { throw "Not in session storage"; } if (oStorage.expired < new Date().getTime()) { sessionStorage.removeItem('tncms.dmp.audiences'); throw "Cache is expired"; } callback(oStorage.audiences); } catch(oException) { if (!window.tncms_siteaud) { window.tncms_siteaud = null; } oScript = document.createElement('script'); oScript.onerror = function() { callback([]); }; oScript.onload = function() { try { var oResult = { audiences:[], expired: new Date().getTime() + 86400000 }; if (!window.tncms_siteaud) { return; } for(var nIdx = 0; nIdx < window.tncms_siteaud.Profile.Audiences.Audience.length; nIdx++) { var sAbbr = window.tncms_siteaud.Profile.Audiences.Audience[nIdx].abbr; oResult.audiences[oResult.audiences.length] = sAbbr; } oResult.audiences.sort(); sessionStorage.setItem('tncms.dmp.audiences', JSON.stringify(oResult)); } catch(oException) { if (console && console.warn) { console.warn('Failed to add behaviors to session storage'); } } callback(oResult.audiences); }; oScript.setAttribute('async', true); oScript.setAttribute('src', '//ad.crwdcntrl.net/5/c=9940/pe=y/var=tncms_siteaud'); var aHead = document.getElementsByTagName("head"); if (aHead && aHead[0]) { if (TNCMS && TNCMS.Tracking) { var oTracker = TNCMS.Tracking.createBucket({ 'app': 'tncms-dmp', 'metric': 'audience-extraction', 'data': { name: 'client', value: 9940 } }); oTracker.addEvent(new Date().getTime()); } aHead[0].appendChild(oScript); } } })(function(aAudiences) { window.TNCMS.Access.push(function() { TNCMS.Access.setAudiences(aAudiences); });}); /*]]>*/</script>
<script src="//s.ntv.io/serve/load.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ca5a9a2f4e5b789d51303b7c20749ccd.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>/*<![CDATA[*/ __tnt.subscription.access.status.check(function(data){
    /* time to consume tracker - time in seconds: 62 */
    setTimeout(function(){
        __tnt.log("Access - validated user view");
        _cc9940.add('act', read_article);_cc9940.bcp();
    }, 31000);
}); /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["ticket","open market","farmhouse collective","food","commerce","economics","internet","auction","jurassic","vendor"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.7047e23fde50ef7dc7625903de95abec.js",
        nativeArticle:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.8cf6eeafd9d2d9371b611e86c7c099c1.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.6dc181cbc3d60e2a1892d05998349ef6.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/nampa/ipt/townnews/commerce';
            
                gptAdSlots['ad-1503253'] = googletag.defineSlot(adUnit, [1,1], 'ad-1503253').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.promo_design_config || (window.promo_design_config = []); window.promo_design_config.push({"button_size":"btn-lg","button_style":"danger","button_text":"Contribute","button_url":"\/contribute","card_shape":"rounded_rectangle","content_text":"Now, more than ever, the world needs trustworthy reporting\u2014but good journalism isn\u2019t free. Please support us by making a contribution.","content_text_color":"light","content_text_shadow":"enabled","display_again":"24","display_timer":"1","display_triggers":"visitor_enter","headline_shadow":"enabled","headline_size":"large","headline_text":"Support local journalism","headline_text_color":"light","image":{},"image_display":"background","overlay_action":"centered","utm_campaign_name":"contribute","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","card_shadow":"enabled","bg_color":"","outline_color":"#ccc","border_width":"5","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon":"exclamation","sticker_icon_color":"white","lead_in":"","lead_text_color":"dark","lead_text_shadow":"disabled","info_text":"","info_text_color":"dark","info_text_shadow":"disabled","enable_email":"","require_user_account":"","signup_lists_only":"","list_ids":"","email_text_color":"dark","email_text_shadow":"disabled","email_button_style":"default","sign_up_text":"Sign up","manage_button_text":"Manage your lists","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","show_audience":"","hide_audience":"","block_id":"1830313"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/nampa/ipt/townnews/commerce';
            
                gptAdSlots['ad-1469104'] = googletag.defineSlot(adUnit, [728,90], 'ad-1469104').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1469104'].setTargeting('pos', ['png_top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/nampa/ipt/townnews/commerce';
            
                gptAdSlots['ad-1469104_mobile'] = googletag.defineSlot(adUnit, [320,50], 'ad-1469104_mobile').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1469104_mobile'].setTargeting('pos', ['png_top']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.facebook.comments.89e3602c68154764e889947868c957c9.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Things To Do | Commerce | idahopress.com</title>
            
    <style>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</style> <link rel="shortcut icon" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/ip-logo-btn.png?_dc=1527607132"> <style> /* Rules for premium icon */ .headline-list .premium-asset-icon { margin-left: 0; margin-right: 0; } /* * Election Tables */ .table-election thead { background: #444; border-color: #444; border-top: 1px solid #444; color: white; font-size: 10px; text-transform: uppercase; } .table-election thead tr, .table-election thead tr th { border-bottom: none; border-color: #444; } .table-election thead th:first-of-type { border-left: 5px solid #444; } .table-election thead th { font-weight: 400; border-color: #444 !important; } .table-election tbody td { border-color: #444; } .table-election .progress { margin-bottom: 0; } .table-election td.dem { border-left: 5px solid blue; } .table-election .progress-bar-dem { background-color: blue; } .table-election td.rep { border-left: 5px solid red; } .table-election .progress-bar-rep { background-color: red; } .table-election td.ind { border-left: 5px solid gray; } .table-election .progress-bar-ind { background-color: gray; } .table-election td.con { border-left: 5px solid #962dce; } .table-election .progress-bar-con { background-color: #962dce; } .table-election td.lib { border-left: 5px solid #e2cc1f; } .table-election .progress-bar-lib { background-color: #e2cc1f; } </style> <style> </style>
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/994970f0-78c2-11e8-9d68-c7a1ab005703.png?resize=180%2C180" />
    
        <link rel="amphtml" href="https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.amp.html" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//connect.facebook.net">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Things To Do | Commerce | idahopress.com" href="http://www.idahopress.com/search/?f=rss&amp;t=article&amp;c=townnews/commerce&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            <!-- page app is editorial url is /townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html--><!-- loading site js -->
        <!-- Global site tag (gtag.js) - AdWords: 804983089 -->
        <script async src="https://www.googletagmanager.com/gtag/js?id=AW-804983089"></script>
        <script>
          window.dataLayer = window.dataLayer || [];
          function gtag(){dataLayer.push(arguments);}
          gtag('js', new Date());
        
          gtag('config', 'AW-804983089');
        </script>
        <script>
          gtag('event', 'page_view', {
            'send_to': 'AW-804983089',
            'user_id': 'replace with value'
          });
        </script>

        
            




        </head>
        <body class="fixed-scroll-nav  blox-asset app-editorial uuid-83b21706-0a2a-5f94-bada-38346fdbe167  section-townnews section-commerce type-article infinity-summary" data-path="/townnews/commerce">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.idahopress.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.57.3&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=pattern&amp;tncms.page.style=default&amp;tncms.page.path=%2Ftownnews%2Fcommerce&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.infinity_scroll.display=summary&amp;tncms.infinity_scroll.order=latest&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=212&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.asset.id=83b21706-0a2a-5f94-bada-38346fdbe167&amp;tncms.asset.app=editorial&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PZ22872&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.57.3&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=pattern&amp;tncms.page.style=default&amp;tncms.page.path=%2Ftownnews%2Fcommerce&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.infinity_scroll.display=summary&amp;tncms.infinity_scroll.order=latest&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=212&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.asset.id=83b21706-0a2a-5f94-bada-38346fdbe167&amp;tncms.asset.app=editorial&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        <div id="service-promo-modal" data-endpoint="https://www.idahopress.com/tncms/subscription/services/?promoCode="  data-software-version="1.32.1">
        <div class="modal fade">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button type="button" class="close" data-dismiss="modal" aria-label="Close">
                            <span aria-hidden="true">&times;</span>
                        </button><h3 id="access-modal-title"></h3>
                    </div>

                    <div class="modal-body">
                        <div class="access-methods-list">
                            <template class="template promo-error-template">
                                <div class="promo-error alert alert-warning">
    <p><strong>Sorry</strong>, an error occurred.</p>
</div></template><template class="template-promo-service hide">
                                <div class="promotion-service subscription-service panel panel-default">
                                    <h3 class="method-header"></h3>
                                    <div class="method-description"></div>
                                    <div class="method-footer">
                                        <a data-subscription-service="" class="method-link btn btn-primary btn-lg">Get Started</a>
                                    </div>
                                </div>
                            </template>

                            <div class="access-login text-center"><div id="access-modal-description"></div>
                                <div class="not-logged-in">
                                    <div id="access-modal-user-links">
    <a class="btn btn-primary btn-lg" href="https://www.idahopress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html">Log In</a>
    <a id="access-registration" class="btn btn-primary btn-lg hidden" href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html">Sign Up</a></div>
                                </div>
                            </div>
                            <div class="clearfix"></div>
                            
                            <h2 class="promo-loading text-center font-larger" style="display:none;"><span class="fas tnt-spinner tnt-spin"></span></h2><div id="access-methods" class="output" data-referer="https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html"></div>
                        </div>
                        <div class="clearfix"></div>
                    </div>
                </div>
            </div>
        </div>
    </div><script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.idahopress.com/tncms/admin/editorial-asset/?edit=83b21706-0a2a-5f94-bada-38346fdbe167"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
    

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left ">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1556588" class="tncms-block">
<div id="site-brand-mark-1556588" class="tncms-block site-brand-mark">
        <section class="block emphasis-h3">
            <div class="block">
                <a href="/"><img class="img-responsive" alt="Idaho Press" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/ip-logo-btn.png?_dc=1527607132"></a></div>
        </section>
    </div>
    <div id="site-follow-us-1556588" class="tncms-block site-follow-us">
        <div class="default">
            <section class="block emphasis-h3">
                <ul class="list-inline">
                    <li><a class="btn btn-xs btn-link fb" href="https://www.facebook.com/Idaho.Press" target="_blank" title="Facebook"><span class="fab tnt-facebook-f"></span></a></li><li><a class="btn btn-xs btn-link fb" href="https://twitter.com/theIdahoPress" target="_blank" title="Twitter"><span class="fab tnt-twitter"></span></a></li><li><a class="btn btn-xs btn-link fb" href="https://www.linkedin.com/company/103648" target="_blank" title="Linkedin"><span class="fab tnt-linkedin-in"></span></a></li><li><a class="btn btn-xs btn-link fb" href="https://www.youtube.com/user/idahopresstribune" target="_blank" title="YouTube"><span class="fab tnt-youtube"></span></a></li><li><a class="btn btn-xs btn-link fb" href="https://www.instagram.com/idahopress/" target="_blank" title="Instagram"><span class="fab tnt-instagram"></span></a></li></ul>
            </section>
        </div>
        <div class="clearfix"></div>
    </div></div><div id="tncms-block-1506245" class="tncms-block apg-js-mobile-login-tweak apg-js-user-controls-dashboard-mobile"><div id="user-controls-1506245" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.idahopress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.idahopress.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1506245').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.idahopress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.idahopress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.idahopress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1506245').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.idahopress.com/users/logout/" id="user-logout-form-1506245"><input type="hidden" name="referer_url" value="https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1909860" class="tncms-block"><script>
    let buttonWrapper = document.querySelector('.apg-js-mobile-login-tweak .not-logged-in .list-inline');
    buttonWrapper.firstElementChild.style.display = 'none';

    let subscribeButton = document.createElement("li");
    subscribeButton.innerHTML = `
    <a href='/subscribe' class='btn btn-primary btn-sm login-btn user-control-link'
        style='background-color: #FF6600; color: white'
    >
        Subscribe
    
`;
    buttonWrapper.appendChild(subscribeButton);
</script></div><div id="tncms-block-1506247" class="tncms-block"><div class="tncms-block site-nav-sections-header">
  <section class="block emphasis-h3"><div class="clearfix">
      <ul class="list-inline block-links pos-top"><li>
          <a class="" href="/subscriptions">
            <span style="color:#ff9900;">Subscriptions from $15.00/mo</span>
          </a>
        </li>
      </ul><div class="drawer-title">
        <div class="drawer-title-inner">
          <h3>Sections</h3>
        </div>
      </div>
    </div>
  </section></div></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/local/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/eyeonboise/"  class="nav-link tnt-section-eye-on-boise">Eye on Boise</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/2cscoop/"  class="nav-link tnt-section-2c-scoop">#2C Scoop</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/state/"  class="nav-link tnt-section-state-news">State News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/national/"  class="nav-link tnt-section-national-news">National News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/world/"  class="nav-link tnt-section-world-news">World News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/elections/"  class="nav-link tnt-section-elections">Elections</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/submissions/"  class="nav-link tnt-section-submit-information">Submit Information</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/newsletter/signup/"  class="nav-link tnt-section-newsletter-signup">Newsletter Signup</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/cavalcade/"  class="nav-link tnt-section-cavalcade-2021">Cavalcade 2021</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/ouridaho/"  class="nav-link tnt-section-our-idaho">Our Idaho</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/coronavirus/"  class="nav-link tnt-section-covid-19">COVID-19</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/highschool/"  class="nav-link tnt-section-high-school">High School</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/blueturfsports/"  class="nav-link tnt-section-boise-state">Boise State</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/colleges/"  class="nav-link tnt-section-college">College</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/localpro/hawks/"  class="nav-link tnt-section-hawks">Hawks</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/localpro/steelheads/"  class="nav-link tnt-section-steelheads">Steelheads</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/national/"  class="nav-link tnt-section-national">National</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/multimedia/"  class="nav-link tnt-section-multimedia">Multimedia</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/outdoors/"  class="nav-link tnt-section-outdoors">Outdoors</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/blogs/sports/"  class="nav-link tnt-section-sports-blogs">Sports Blogs</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/multimedia/photos/"  class="nav-link tnt-section-photo-gallery">Photo Gallery</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sportsstars/"  class="nav-link tnt-section-2020-sports-stars">2020 Sports Stars</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/letter/"  class="nav-link tnt-section-submit-a-letter-to-the-editor">Submit a Letter to the Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/guest_opinion/"  class="nav-link tnt-section-submit-a-guest-opinion">Submit a guest opinion</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/submit_cheer/"  class="nav-link tnt-section-submit-cheers-and-jeers">Submit Cheers and Jeers</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editors_notebook/"  class="nav-link tnt-section-editors-notebook">Editor's Notebook</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/cheers_and_jeers/"  class="nav-link tnt-section-cheers-jeers">Cheers & Jeers</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest_opinion/"  class="nav-link tnt-section-guest-opinions">Guest Opinions</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/columnists/"  class="nav-link tnt-section-columnists">Columnists</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://idahopress.secondstreetapp.com/Best-of-Canyon-County-2020"  target="_blank" rel="noopener" class="nav-link tnt-section-best-of-canyon-county-2020">Best of Canyon County 2020</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/holiday-bazaar/"  class="nav-link tnt-section-holiday-bazaar-blast">Holiday Bazaar Blast</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/announcements"  class="nav-link tnt-section-announcements">Announcements</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/community_columns/"  class="nav-link tnt-section-columns">Columns</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/life/"  class="nav-link tnt-section-life">Life</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/farm_ranch/"  class="nav-link tnt-section-farm-ranch">Farm & Ranch</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://ontvtoday.com"  target="_blank" rel="noopener" class="nav-link tnt-section-tv-listings">TV Listings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/outdoors/"  class="nav-link tnt-section-outdoors">Outdoors</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/submissions/"  class="nav-link tnt-section-submit-information">Submit Information</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/taco_trials/"  class="nav-link tnt-section-taco-trials">Taco Trials</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/boisedev/"  class="nav-link tnt-section-dev">Dev</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/spotlight/"  class="nav-link tnt-section-spotlight">Spotlight</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/two-wheeled_wanderer"  class="nav-link tnt-section-two-wheeled-wanderer">Two-wheeled Wanderer</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/health/"  class="nav-link tnt-section-health">Health</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="https://www.legacy.com/obituaries/idahopress/"  target="_blank" rel="noopener" class="nav-link tnt-section-obits">Obits</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/obituaries/place-an-obituary"  class="nav-link tnt-section-place-an-obituary">Place an obituary</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.legacy.com/obituaries/idahopress"  target="_blank" rel="noopener" class="nav-link tnt-section-view-all-obituaries">View all obituaries</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-browse-classifieds">Browse classifieds</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://careers.idahopress.com"  target="_blank" rel="noopener" class="nav-link tnt-section-careers">Careers</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://auctions.idahopress.com"  target="_blank" rel="noopener" class="nav-link tnt-section-auctions">Auctions</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://realestate.idahopress.com/ "  target="_blank" rel="noopener" class="nav-link tnt-section-real-estate">Real Estate</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://services.idahopress.com"  target="_blank" rel="noopener" class="nav-link tnt-section-service-directory">Service Directory</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/place-an-ad/"  class="nav-link tnt-section-place-an-ad">Place an Ad</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/local-events/"  class="nav-link tnt-section-local-events">Local Events</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-middle-left-region" class="tncms-region "><div id="tncms-block-1268830" class="tncms-block"><section id="block-1268830" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1268830" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1268830" aria-labelledby="site-search-button-1268830" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-sm form-control">
        <input id="site-search-1268830-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1268830-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1268830-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1268830').submit();
        return false;
    });

    $('#site-search-1268830').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1268830 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1268830 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1268830-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-1510435" class="tncms-block"><div class="tncms-region-nav" id="htmlHardcoded-region-nav-mobile-nav-left-middle">
	<div class="panel-group nav navbar-nav" id="mobile-nav-left-middle_menu" role="tablist">
		
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a aria-controls="mobile-nav-left-middle_menu-child-1" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-middle_menu-child-1" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/special_report/">Special Reports</a>
				</div>
			</div>
			<ul class="collapse nav navbar-nav" id="mobile-nav-left-middle_menu-child-1">
<li>
					<a href="/special_report/criminal_justice/">Criminal Justice</a>
				</li>
				<li>
					<a href="/special_report/rapekits/">Rape Kits</a>
				</li>
				<li>
					<a href="/special_report/domesticviolence/">Domestic Violence</a>
				</li>
				<li>
					<a href="/special_report/homeless/">Homeless</a>
				</li>
				<li>
					<a href="/special_report/publictransit/">Public Transit</a>
				</li>
				<li>
					<a href="/special_report/immigration/">Immigration</a>
				</li>
				<li>
					<a href="/special_report/salute/">Salute</a>
				</li>
			</ul>
</div>
    
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a aria-controls="mobile-nav-left-middle_menu-child-2" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-middle_menu-child-2" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/special_sections/">Special Sections</a>
				</div>
			</div>
			<ul class="collapse nav navbar-nav" id="mobile-nav-left-middle_menu-child-2">
<li>
					<a href="https://www.idahopress.com/cavalcade/">Cavalcade</a>
				</li>
				<li>
					<a href="">Explore</a>
				</li>
				<li>
					<a href="https://www.idahopress.com/101/">101 Things to Do</a>
				</li>
				<li>
					<a href="http://www.buyidaho.org/Directory" target="_blank">Buy Idaho Directory</a>
				</li>
				<li>
					<a href="https://www.idahopress.com/community/health/stampede-for-the-cure-racks-up-big-bucks/article_6584b0d0-ddc9-52e1-88aa-1c5569f777b9.html">Snake River Stampede</a>
				</li>
				<li>
					<a href="https://www.idahopress.com/sports/photos-caldwell-night-rodeo-goes-out-with-a-bang/article_0a095acb-2afa-558e-9cc0-f5ca89fb0123.html">Caldwell Night Rodeo</a>
				</li>
				<li>
					<a href="">Football Preview</a>
				</li>
				<li>
					<a href="http://www.nampa.com/list/" target="_blank">Nampa Chamber Directory</a>
				</li>
			</ul>
</div>

                <div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a href="/eedition/?utm_source=redesign&amp;utm_medium=web&amp;utm_campaign=2018&amp;utm_term=eedition&amp;utm_content=slidemenu"><span class="topbarLink"><i aria-hidden="true" class="fas tnt-newspaper"></i> Read the E-Edition</span></a>
				</div>
			</div>
		</div>
                <div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a href="/marketplace" target="_blank"><i aria-hidden="true" class="fas tnt-map-marker-alt"></i> Business Directory</a>
				</div>
			</div>
		</div>
    
	</div>
</div></div></div>
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "><div id="tncms-block-1510446" class="tncms-block"><div class="tncms-region-nav" id="htmlHardcoded-region-nav-mobile-nav-left-below">
	<div class="panel-group nav navbar-nav" id="mobile-nav-left-bottom_menu" role="tablist">
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a aria-controls="mobile-nav-left-bottom_menu-child-1" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-1" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/customerservice/"><i aria-hidden="true" class="fas tnt-cog"></i> Subscriber Services</a>
				</div>
			</div>
			<ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-1"><li>
					<a href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?nwmessage=The+login+and+password+could+not+be+validated.+&amp;login_id=undefined" target="_blank">Start A Subscription</a>
				</li>
				<li>
					<a href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?nwmessage=The+login+and+password+could+not+be+validated.+&amp;login_id=undefined" target="_blank">Manage Your Subscription</a>
				</li>
				<li>
					<a href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?nwmessage=The+login+and+password+could+not+be+validated.+&amp;login_id=undefined" target="_blank">Make A Payment</a>
				</li>
				<li>
					<a href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?nwmessage=The+login+and+password+could+not+be+validated.+&amp;login_id=undefined" target="_blank">Stop Your Paper For Vacation</a>
				</li>
				<li>
					<a href="https://apg05.newzware.com/ss70v2/adams/common/template.jsp?nwmessage=The+login+and+password+could+not+be+validated.+&amp;login_id=undefined" target="_blank">Report A Delivery Issue</a>
				</li>
				<li>
					<a href="/newsletter/signup/">Get our newsletters</a>
				</li>
			</ul></div>
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a aria-controls="mobile-nav-left-bottom_menu-child-2" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-2" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a><i aria-hidden="true" class="fas tnt-bullhorn"></i> Make An Announcement</a>
				</div>
			</div>
			<ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-2"><li>
					<a href="/site/forms/announcements/anniversary/">Anniversary</a>
				</li>
				<li>
					<a href="/site/forms/announcements/birth/">Birthdays</a>
				</li>
				<li>
					<a href="/site/forms/announcements/engagement/">Engagement</a>
				</li>
				<li>
					<a href="/site/forms/announcements/wedding/">Wedding</a>
				</li>
			</ul></div>
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a aria-controls="mobile-nav-left-bottom_menu-child-3" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-3" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/site/services"><i aria-hidden="true" class="fas tnt-cubes"></i> Site Services</a>
				</div>
			</div>
			<ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-3"><li>
					<a href="/newsletter/signup/">Get our newsletters</a>
				</li>
				<li>
					<a href="/site/about/">About Us</a>
				</li>
				<li>
					<a href="/site/contact/">Contact Us</a>
				</li>
				<li>
					<a href="/site/advertising/">Advertising</a>
				</li>
				<li>
					<a href="https://classadz.vdata.com/Nampa/ClsSelectClass.aspx" target="_blank">Place A Classified Ad</a>
				</li>
				<li>
					<a href="https://portal.cityspark.com/EventEntry/EventEntry/IdahoPressTribune" target="_blank">Add A Calendar Event</a>
				</li>
				<li>
					<a href="/site/sponsorships/">Sponsorships</a>
				</li>
				<li>
					<a href="/site/nie">Newspapers In Education</a>
				</li>
				<li>
					<a href="/multimedia/">Multimedia</a>
				</li>
				<li>
					<a href="/multimedia/photos/">Photo Gallery</a>
				</li>
                                
				<li>
					<a href="/multimedia/podcasts/">Podcasts</a>
				</li>
			</ul></div>
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
                                        <a href="https://apgwest.newsbank.com/"><span class="topbarLink"><i class="fas tnt-list-ul"></i> Browse the Archives</span></a>
				</div>
			</div>
		</div>
	</div>
</div></div></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-12">
        <div id="tncms-region-topbar-col-one" class="tncms-region "><div id="tncms-block-1556590" class="tncms-block">
<style>
        #swap-toggle-decor-before {
            border-top: 8px solid #688a7e;
        }
        #swap-toggle-ipt:hover, #swap-toggle-ipt.active {
            background-color: #688a7e;
        }#swap-toggle-bw:hover, #swap-toggle-bw.active {
                background-color: #cd2524;
            }#swap-toggle-kmn:hover, #swap-toggle-kmn.active {
                background-color: #a2c134;
            }#swap-toggle-mp:hover, #swap-toggle-mp.active {
                background-color: #58a0da;
            }#swap-toggle-emi:hover, #swap-toggle-emi.active {
                background-color: #026fad;
            }#swap-toggle-bts:hover, #swap-toggle-bts.active {
                background-color: #09347a;
            }#swap-toggle-eob:hover, #swap-toggle-eob.active {
                background-color: #688a7e;
            }#swap-toggle-fr:hover, #swap-toggle-fr.active {
                background-color: #ad0736;
            }</style>
    
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
    
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
    
    
        <div class="png-header-swap-nav-wrap" data-where="main">
            <div class="png-header-swap-nav">
                <a id="swap-toggle-ipt" class="png-header-swap-menu-item active" data-id="header-splash-ipt" data-color="#688a7e" data-invert="" href="/">Idaho Press</a><a id="swap-toggle-bw" class="png-header-swap-menu-item" data-id="header-splash-bw" data-color="#cd2524" data-invert="" href="/boiseweekly">Boise Weekly</a><a id="swap-toggle-kmn" class="png-header-swap-menu-item" data-id="header-splash-kmn" data-color="#a2c134" data-invert="" href="/kuna">Kuna Melba News</a><a id="swap-toggle-mp" class="png-header-swap-menu-item" data-id="header-splash-mp" data-color="#58a0da" data-invert="" href="/meridian">Meridian Press</a><a id="swap-toggle-emi" class="png-header-swap-menu-item" data-id="header-splash-emi" data-color="#026fad" data-invert="" href="/emmett">Messenger-Index</a><a id="swap-toggle-bts" class="png-header-swap-menu-item" data-id="header-splash-bts" data-color="#09347a" data-invert="" href="/blueturfsports">Blue Turf Sports</a><a id="swap-toggle-eob" class="png-header-swap-menu-item" data-id="header-splash-eob" data-color="#688a7e" data-invert="" href="/eyeonboise">Eye On Boise</a><a id="swap-toggle-fr" class="png-header-swap-menu-item" data-id="header-splash-fr" data-color="#ad0736" data-invert="" href="http://www.postregister.com/farmandranch" target="_blank">Farm & Ranch</a><div id="swap-toggle-decor-wrap">
                    <div id="swap-toggle-decor">
                        <div id="swap-toggle-decor-before"></div>
                        <div id="swap-toggle-decor-after"></div>
                    </div>
                </div>
            </div>
        </div>
    </div></div>
        
    </div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12">
                        <div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-1556589" class="tncms-block mysteryHeaderLogo">
<style>
        body #site-header-container {
            background-color: #789e91;
            background: #789e91;
            background: -moz-linear-gradient(top, #688a7e 0%, #789e91 100%);
            background: -webkit-linear-gradient(top, #688a7e 0%, #789e91 100%);
            background: linear-gradient(to bottom, #688a7e 0%, #789e91 100%);
            filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#688a7e', endColorstr='#789e91',GradientType=0 );
        }
        
            body.section-boiseweekly #site-header-container {
                background-color: #cd2524;
                background: #cd2524;
                background: -moz-linear-gradient(top, #cd2524 0%, #cd2524 100%);
                background: -webkit-linear-gradient(top, #cd2524 0%,#cd2524 100%);
                background: linear-gradient(to bottom, #cd2524 0%,#cd2524 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#cd2524', endColorstr='#cd2524',GradientType=0 );
            }
        
            body.section-kuna #site-header-container {
                background-color: #a2c134;
                background: #a2c134;
                background: -moz-linear-gradient(top, #a2c134 0%, #BAD45A 100%);
                background: -webkit-linear-gradient(top, #a2c134 0%,#BAD45A 100%);
                background: linear-gradient(to bottom, #a2c134 0%,#BAD45A 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#a2c134', endColorstr='#BAD45A',GradientType=0 );
            }
        
            body.section-meridian #site-header-container {
                background-color: #58a0da;
                background: #58a0da;
                background: -moz-linear-gradient(top, #58a0da 0%, #7fb6e3 100%);
                background: -webkit-linear-gradient(top, #58a0da 0%,#7fb6e3 100%);
                background: linear-gradient(to bottom, #58a0da 0%,#7fb6e3 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#58a0da', endColorstr='#7fb6e3',GradientType=0 );
            }
        
            body.section-emmett #site-header-container {
                background-color: #026fad;
                background: #026fad;
                background: -moz-linear-gradient(top, #026fad 0%, #1896ed 100%);
                background: -webkit-linear-gradient(top, #026fad 0%,#1896ed 100%);
                background: linear-gradient(to bottom, #026fad 0%,#1896ed 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#026fad', endColorstr='#1896ed',GradientType=0 );
            }
        
            body.section-blueturfsports #site-header-container {
                background-color: #0169C2;
                background: #0169C2;
                background: -moz-linear-gradient(top, #09347a 0%, #0169C2 100%);
                background: -webkit-linear-gradient(top, #09347a 0%,#0169C2 100%);
                background: linear-gradient(to bottom, #09347a 0%,#0169C2 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#09347a', endColorstr='#0169C2',GradientType=0 );
            }
        
            body.section-eyeonboise #site-header-container {
                background-color: #789e91;
                background: #789e91;
                background: -moz-linear-gradient(top, #688a7e 0%, #789e91 100%);
                background: -webkit-linear-gradient(top, #688a7e 0%,#789e91 100%);
                background: linear-gradient(to bottom, #688a7e 0%,#789e91 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#688a7e', endColorstr='#789e91',GradientType=0 );
            }
        
            body.section-http://www.postregister.com/farmandranch #site-header-container {
                background-color: #ad0736;
                background: #ad0736;
                background: -moz-linear-gradient(top, #ad0736 0%, #ad0736 100%);
                background: -webkit-linear-gradient(top, #ad0736 0%,#ad0736 100%);
                background: linear-gradient(to bottom, #ad0736 0%,#ad0736 100%);
                filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#ad0736', endColorstr='#ad0736',GradientType=0 );
            }
        
    
        
                    #site-header-container {
                        position: relative;
                    }
                    #site-header-container::before {
                        content: '';
                        position: absolute;
                        top:10px;left:0;right:0;bottom:0;
                        background-color: #fff;
                    }
                    
    </style>
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
            
        
        
            <div class="site-logo-container text-left">
                <a href="/" title="Idaho Press"><img class="img-responsive" alt="Idaho Press" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/ip-logo-main.png?_dc=1528389382"></a>
            </div>
        </div><div id="tncms-block-1583594" class="tncms-block">

    <style>
              .carrierbutton {
		font-family: verdana;
		font-weight: 600;
		font-size: 15px;
		line-height: 15px;
		color: black;
		background-color:#95f20a;
		border:  5px solid #95f20a;
		border-radius: 25px;
		text-align: center;
		text-decoration: none;
		display: inline-block;
		cursor: pointer;
                margin-top: 0px;
                margin-left: 60px;
               }
                 #siteHeaderContainerCTA {
                    display: block;
                    position: absolute;
                    top: 0;
                    right: 0;
                    width: 400px;
                    height: 100px;
                    padding-top: 5px;
                    overflow: hidden;
                    text-align: center;
                }
                #siteHeaderContainerCTA:hover {
                    text-decoration: none;
                }
                 #siteHeaderContainerCTA .siteHeaderContainerCTA-line1 {
                    font-weight: 700;
                    font-size: 24px;
                    line-height: 24px;
                    color: black;
                    background-color:orange;
                    border:  1px solid orange;
                    border-radius: 25px;
                    width:250px; margin:auto;
                }

                }
                 #siteHeaderContainerCTA .siteHeaderContainerCTA-line2 {
                    font-weight: 700;
                    font-size: 18px;
                    line-height: 24px;
                    color: #a4a9ad;
                    margin-top:10px;
                }
                #siteHeaderContainerCTA .siteHeaderContainerCTA-line3 {
                    font-weight: 700;
                    font-size: 21px;
                    line-height: 30px;
                    color: #55565a;
                    transition: all 200ms ease;
                }
                #siteHeaderContainerCTA:hover .siteHeaderContainerCTA-line3 {
                    color: #111820;
                }
                .mysteryHeaderLogo {
                    margin-top:  0px;
                }
                .mysteryHeaderSocial {
                    margin-top: 100px;
                }
                .mysteryHeaderWeather {
                    margin-top: 100px;
                }
            </style>
        
        
        
    
        <div class="carrierbutton"><a href="https://www.idahopress.com/site/forms/subscription_services/carrier_application/" target="_blank">&nbsp;BECOME A CARRIER&nbsp;</a></div>
    
    
    <a id="siteHeaderContainerCTA" href="/subscribe">
            <div class="siteHeaderContainerCTA-line1">SUBSCRIBE NOW!</div>
            <div class="siteHeaderContainerCTA-line2">$3.50 a week for</div>
            <div class="siteHeaderContainerCTA-line3">52 WEEKS</div>
        </a>
        </div><div id="tncms-block-1580753" class="tncms-block mysteryHeaderSocial">

    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
        
    
    
        <div class="follow-links-1580753">
            <section id="block-1580753" class="block emphasis-h3   ">
                <ul class="list-inline"><style>
                                    #site-header-container .mysteryHeaderSocial .block ul.list-inline li a.btn {background-color:#58585a;}
                                    #site-header-container .mysteryHeaderSocial .block ul.list-inline li a.btn:hover {background-color:#38383a;}
                                </style><li><a href="https://www.facebook.com/Idaho.Press" title="Facebook" target="_blank" class="btn btn-md btn-link"><i class="fab tnt-facebook-f"></i><span class="sr-only">Facebook</span></a></li><li><a href="https://twitter.com/theIdahoPress" title="Twitter" target="_blank" class="btn btn-md btn-link"><i class="fab tnt-twitter"></i><span class="sr-only">Twitter</span></a></li><li><a href="https://www.linkedin.com/company/103648" title="Linkedin" target="_blank" class="btn btn-md btn-link"><i class="fab tnt-linkedin-in"></i><span class="sr-only">Linkedin</span></a></li><li><a href="https://www.youtube.com/user/idahopresstribune" title="YouTube" target="_blank" class="btn btn-md btn-link"><i class="fab tnt-youtube"></i><span class="sr-only">YouTube</span></a></li><li><a href="https://www.instagram.com/idahopress/" title="Instagram" target="_blank" class="btn btn-md btn-link"><i class="fab tnt-instagram"></i><span class="sr-only">Instagram</span></a></li></ul>
            </section>
        </div>
        <div class="clearfix"></div>
    </div><div id="tncms-block-1580754" class="tncms-block mysteryHeaderWeather">
<style>
            #site-header-container #weather-1580754 .current-conditions a { color:#58585a; }
            #site-header-container #weather-1580754 .current-conditions a:hover { color:#38383a; }
        </style>
        <div id="weather-1580754" class="weather-current size-medium pull-right ">
            <ul class="list-unstyled">
                <li class="current-conditions ">
                    <a href="/weather/?weather_zip=83651" class="dropdown-toggle" >
                        <span class="icon pull-left">
                            
                            <span class="fas tnt-wi-night-clear"></span>
                        </span>
                        <span class="pull-left temp-desc medium">
                            <span class="temp">68&deg;</span>
                            
                                <span class="cond">Partly Cloudy </span>
                            
                        </span>
                        <span class="clearfix"></span>
                    </a>
                    
                </li>
            </ul>
        </div>
        
            <div class="clearfix"></div>
        </div></div>
                    </div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12">
                        <div id="tncms-region-masthead-full-bottom" class="tncms-region "><div id="tncms-block-1929275" class="tncms-block"><style>
.apg-alert-bw {
    background-color: #b2c5be;
    color: black;
}
</style><div class="grid" style="padding-top: 20px;">
<div class="row">
    <div class="alert apg-alert-bw" role="alert">
We've recently updated our online systems. If you can't login please try resetting your password. You must login with an email address. If you don't have an email associated with your account email 
<a href="mailto:circulation@idahopress.com" style="font-weight: bold;">circulation@idahopress.com</a> for help creating one. 
    </div>
</div>
</div></div></div>
                    </div>
                </div>
                
            </header>
        </div>
    

    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle " data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar" style='margin: 0 auto 4px auto;'></span>
                            <span class="icon-bar" style='margin: 0 auto 4px auto;'></span>
                            <span class="icon-bar" style='margin: 0 auto;'></span>
                            <span class="visible-lg visible-md sr-only-show">Full Menu</span>
                        </button>
                        
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1556587" class="tncms-block">
<div id="site-logo-1556587" class="site-logo-container swap-site-mobile">
        <div class="logo-middle swap-site-mobile-current">
            <a href="/" title="Idaho Press"><img class="img-responsive" alt="Idaho Press" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/ip-logo-mobile.png?_dc=1527607166"></a><div id="swap-site-mobile-choice-trigger"><i class="fas tnt-chevron-down" aria-hidden="true"></i></div>
        </div>
        <div id="swap-site-mobile-choices">
            <a href="/" title="Idaho Press"><img class="img-responsive" alt="Idaho Press" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/ip-logo-btn-sm.png?_dc=1527607120">Idaho Press</a><a href="/boiseweekly" title="Boise Weekly"><img class="img-responsive" alt="Boise Weekly" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/bw-logo-btn-sm.png?_dc=1569942714">Boise Weekly</a><a href="/kuna" title="Kuna Melba News"><img class="img-responsive" alt="Kuna Melba News" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/kmn-logo-btn-sm.png?_dc=1523464503">Kuna Melba News</a><a href="/meridian" title="Meridian Press"><img class="img-responsive" alt="Meridian Press" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/mp-logo-btn-sm.png?_dc=1523464597">Meridian Press</a><a href="/emmett" title="Messenger-Index"><img class="img-responsive" alt="Messenger-Index" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/emi-logo-btn-sm.png?_dc=1524601636">Messenger-Index</a><a href="/blueturfsports" title="Blue Turf Sports"><img class="img-responsive" alt="Blue Turf Sports" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/bts-logo-btn-sm.png?_dc=1523464232">Blue Turf Sports</a><a href="/eyeonboise" title="Eye On Boise"><img class="img-responsive" alt="Eye On Boise" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/ip-logo-btn-sm.png?_dc=1527607120">Eye On Boise</a><a href="http://www.postregister.com/farmandranch" target="_blank" title="Farm & Ranch"><img class="img-responsive" alt="Farm & Ranch" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/fr-logo-btn-sm.png?_dc=1530628411">Farm & Ranch</a></div>
    </div></div></div>
                            
                        </div>
                    

                                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1506238" class="tncms-block"><ul id="site-search-1506238-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1506238" aria-labelledby="site-search-button-1506238" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-sm ">
        <input id="site-search-1506238-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1506238-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-1506238" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-1506238-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1506238').submit();
        return false;
    });

    $('#site-search-1506238').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1506238 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1506238 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1506238-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-1506241" class="tncms-block pull-right apg-js-user-controls-dashboard"><div id="user-controls-1506241" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="nav navbar-nav navbar-right"><li><a  onclick="javascript:void(0); return false;"  data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" class="user-control-link" rel="nofollow">
                        <span class="fas tnt-user"></span>
                    </a>
                    <ul class="dropdown-menu dropdown-menu-right" role="menu">
                        <li>
                            <div style="width: 300px; padding: 15px">
                                <div class="row padding-bottom">
                                    <div class="col-md-12">
                                        <h4>Log In Using Your Account</h4>
                                        <a role="menuitem" class="btn btn-block btn-primary" href="https://www.idahopress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html" rel="nofollow">Log In</a>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-md-12">
                                        <div class="dropdown-signup"><strong>Don't have an account?</strong> <a role="menuitem" href="/tncms/auth/begin/?provider=Newzware&return=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html" rel="nofollow">Sign Up Today</a></div>
                                    </div>
                                </div>
                            </div>
                        </li>
                    </ul>
                </li>
        </ul>
    </div>

    <div class="logged-in">
        
        
        <ul class="nav navbar-nav navbar-right">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.idahopress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.idahopress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.idahopress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1506241').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.idahopress.com/users/logout/" id="user-logout-form-1506241"><input type="hidden" name="referer_url" value="https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1929278" class="tncms-block"><script>
let selector = ".apg-js-user-controls-dashboard .logged-in .nav .dropdown .dropdown-menu li"
let dashBoardLink = document.querySelectorAll(selector)[1];
dashBoardLink.querySelector('a').href = "https://apg05.newzware.com/ss70v2/adams/common/template.jsp?autoLogout=N&nwmodule=main&nwpage=main";

selector = ".apg-js-user-controls-dashboard-mobile .logged-in .list-inline li"
dashBoardLink = document.querySelectorAll(selector)[0];
dashBoardLink.querySelector('a').href = "https://apg05.newzware.com/ss70v2/adams/common/template.jsp?autoLogout=N&nwmodule=main&nwpage=main";

</script></div></div>
                                <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link   tnt-section-subscribe"  href="/subscriptions"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition?utm_source=redesign&amp;utm_medium=web&amp;utm_campaign=2018&amp;utm_term=eedition&amp;utm_content=menu"  tabindex="0">
                    <span class="nav-label">E-edition</span>
                </a></li></ul></div>
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-local-news"  href="/news/local/"  tabindex="0">
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-eye-on-boise"  href="/eyeonboise/"  tabindex="0">
                    <span class="nav-label">Eye on Boise</span>
                </a></li><li>
                <a class="nav-link   tnt-section-2c-scoop"  href="/2cscoop/"  tabindex="0">
                    <span class="nav-label">#2C Scoop</span>
                </a></li><li>
                <a class="nav-link   tnt-section-state-news"  href="/news/state/"  tabindex="0">
                    <span class="nav-label">State News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-national-news"  href="/news/national/"  tabindex="0">
                    <span class="nav-label">National News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-world-news"  href="/news/world/"  tabindex="0">
                    <span class="nav-label">World News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-elections"  href="/elections/"  tabindex="0">
                    <span class="nav-label">Elections</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-information"  href="/site/submissions/"  tabindex="0">
                    <span class="nav-label">Submit Information</span>
                </a></li><li>
                <a class="nav-link   tnt-section-newsletter-signup"  href="/newsletter/signup/"  tabindex="0">
                    <span class="nav-label">Newsletter Signup</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cavalcade-2021"  href="/cavalcade/"  tabindex="0">
                    <span class="nav-label">Cavalcade 2021</span>
                </a></li><li>
                <a class="nav-link   tnt-section-our-idaho"  href="/ouridaho/"  tabindex="0">
                    <span class="nav-label">Our Idaho</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-covid-19"  href="/coronavirus/"  tabindex="0">
                    <span class="nav-label">COVID-19</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-high-school"  href="/sports/highschool/"  tabindex="0">
                    <span class="nav-label">High School</span>
                </a></li><li>
                <a class="nav-link   tnt-section-boise-state"  href="/blueturfsports/"  tabindex="0">
                    <span class="nav-label">Boise State</span>
                </a></li><li>
                <a class="nav-link   tnt-section-college"  href="/sports/colleges/"  tabindex="0">
                    <span class="nav-label">College</span>
                </a></li><li>
                <a class="nav-link   tnt-section-hawks"  href="/sports/localpro/hawks/"  tabindex="0">
                    <span class="nav-label">Hawks</span>
                </a></li><li>
                <a class="nav-link   tnt-section-steelheads"  href="/sports/localpro/steelheads/"  tabindex="0">
                    <span class="nav-label">Steelheads</span>
                </a></li><li>
                <a class="nav-link   tnt-section-national"  href="/sports/national/"  tabindex="0">
                    <span class="nav-label">National</span>
                </a></li><li>
                <a class="nav-link   tnt-section-multimedia"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Multimedia</span>
                </a></li><li>
                <a class="nav-link   tnt-section-outdoors"  href="/sports/outdoors/"  tabindex="0">
                    <span class="nav-label">Outdoors</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports-blogs"  href="/blogs/sports/"  tabindex="0">
                    <span class="nav-label">Sports Blogs</span>
                </a></li><li>
                <a class="nav-link   tnt-section-photo-gallery"  href="/multimedia/photos/"  tabindex="0">
                    <span class="nav-label">Photo Gallery</span>
                </a></li><li>
                <a class="nav-link   tnt-section-2020-sports-stars"  href="/sportsstars/"  tabindex="0">
                    <span class="nav-label">2020 Sports Stars</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-submit-a-letter-to-the-editor"  href="/site/forms/online_services/letter/"  tabindex="0">
                    <span class="nav-label">Submit a Letter to the Editor</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-a-guest-opinion"  href="/site/forms/online_services/guest_opinion/"  tabindex="0">
                    <span class="nav-label">Submit a guest opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-cheers-and-jeers"  href="/site/forms/online_services/submit_cheer/"  tabindex="0">
                    <span class="nav-label">Submit Cheers and Jeers</span>
                </a></li><li>
                <a class="nav-link   tnt-section-editors-notebook"  href="/opinion/editors_notebook/"  tabindex="0">
                    <span class="nav-label">Editor's Notebook</span>
                </a></li><li>
                <a class="nav-link   tnt-section-letters-to-the-editor"  href="/opinion/editor/"  tabindex="0">
                    <span class="nav-label">Letters to the Editor</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cheers-jeers"  href="/opinion/cheers_and_jeers/"  tabindex="0">
                    <span class="nav-label">Cheers & Jeers</span>
                </a></li><li>
                <a class="nav-link   tnt-section-guest-opinions"  href="/opinion/guest_opinion/"  tabindex="0">
                    <span class="nav-label">Guest Opinions</span>
                </a></li><li>
                <a class="nav-link   tnt-section-columnists"  href="/opinion/columnists/"  tabindex="0">
                    <span class="nav-label">Columnists</span>
                </a></li><li>
                <a class="nav-link   tnt-section-editorials"  href="/opinion/editorials/"  tabindex="0">
                    <span class="nav-label">Editorials</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-community"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/community/"  tabindex="0">
                    <span class="nav-label">Community</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-best-of-canyon-county-2020"  href="http://idahopress.secondstreetapp.com/Best-of-Canyon-County-2020"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Best of Canyon County 2020</span>
                </a></li><li>
                <a class="nav-link   tnt-section-holiday-bazaar-blast"  href="/community/holiday-bazaar/"  tabindex="0">
                    <span class="nav-label">Holiday Bazaar Blast</span>
                </a></li><li>
                <a class="nav-link   tnt-section-announcements"  href="/community/announcements"  tabindex="0">
                    <span class="nav-label">Announcements</span>
                </a></li><li>
                <a class="nav-link   tnt-section-columns"  href="/community/community_columns/"  tabindex="0">
                    <span class="nav-label">Columns</span>
                </a></li><li>
                <a class="nav-link   tnt-section-life"  href="/community/life/"  tabindex="0">
                    <span class="nav-label">Life</span>
                </a></li><li>
                <a class="nav-link   tnt-section-farm-ranch"  href="/community/farm_ranch/"  tabindex="0">
                    <span class="nav-label">Farm & Ranch</span>
                </a></li><li>
                <a class="nav-link   tnt-section-tv-listings"  href="https://ontvtoday.com"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">TV Listings</span>
                </a></li><li>
                <a class="nav-link   tnt-section-outdoors"  href="/outdoors/"  tabindex="0">
                    <span class="nav-label">Outdoors</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submit-information"  href="/site/submissions/"  tabindex="0">
                    <span class="nav-label">Submit Information</span>
                </a></li><li>
                <a class="nav-link   tnt-section-taco-trials"  href="/community/taco_trials/"  tabindex="0">
                    <span class="nav-label">Taco Trials</span>
                </a></li><li>
                <a class="nav-link   tnt-section-dev"  href="/boisedev/"  tabindex="0">
                    <span class="nav-label">Dev</span>
                </a></li><li>
                <a class="nav-link   tnt-section-spotlight"  href="/community/spotlight/"  tabindex="0">
                    <span class="nav-label">Spotlight</span>
                </a></li><li>
                <a class="nav-link   tnt-section-two-wheeled-wanderer"  href="/community/two-wheeled_wanderer"  tabindex="0">
                    <span class="nav-label">Two-wheeled Wanderer</span>
                </a></li><li>
                <a class="nav-link   tnt-section-health"  href="/community/health/"  tabindex="0">
                    <span class="nav-label">Health</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-obits"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="https://www.legacy.com/obituaries/idahopress/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Obits</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-place-an-obituary"  href="/obituaries/place-an-obituary"  tabindex="0">
                    <span class="nav-label">Place an obituary</span>
                </a></li><li>
                <a class="nav-link   tnt-section-view-all-obituaries"  href="https://www.legacy.com/obituaries/idahopress"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">View all obituaries</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-browse-classifieds"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Browse classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-careers"  href="https://careers.idahopress.com"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Careers</span>
                </a></li><li>
                <a class="nav-link   tnt-section-auctions"  href="https://auctions.idahopress.com"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Auctions</span>
                </a></li><li>
                <a class="nav-link   tnt-section-real-estate"  href="http://realestate.idahopress.com/ "  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Real Estate</span>
                </a></li><li>
                <a class="nav-link   tnt-section-service-directory"  href="https://services.idahopress.com"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Service Directory</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-an-ad"  href="/place-an-ad/"  tabindex="0">
                    <span class="nav-label">Place an Ad</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-local-events"  href="/local-events/"  tabindex="0">
                    <span class="nav-label">Local Events</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        </div>
        
            
                <script>
                    jQuery(document).ready(function($){
                        var sNavContainer = '#site-navbar-container';
                        var sBodyContainer = '#main-body-container';
                        var sNavHeight = $(sNavContainer).height();
                        var iUnfixPoint = 0;
                        if( __tnt.client.platform.ios ){
                            $(sNavContainer).addClass('affix-sticky');
                        } else {
                            $sNavScroll = false;
                            $(window).on('scroll mousewheel', function(){
                                if( !$sNavScroll ){
                                    $sNavScroll = true;
                                    setTimeout(function(){
                                        var iFixPoint = $(sNavContainer).offset().top;
                                        var iCurrPoint = $(this).scrollTop();
                                        if( iCurrPoint >= iFixPoint && iCurrPoint > iUnfixPoint ){
                                            if( !$(sNavContainer).hasClass('affix') ){ 
                                                iUnfixPoint = iFixPoint;
                                                $(sNavContainer).addClass('affix').removeClass('affix-top');
                                                $(sBodyContainer).css('margin-top', sNavHeight+'px'); 
                                            }
                                        } else {
                                            if( !$(sNavContainer).hasClass('affix-top') ){ 
                                                $(sNavContainer).removeClass('affix').addClass('affix-top');
                                                $(sBodyContainer).css('margin-top', 0);
                                            }
                                        }
                                        $sNavScroll = false;
                                    }, 25);
                                }
                            });
                        }
                    });
                </script>
            
        
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1505697" class="tncms-block no-rounded-corners"></div><div id="tncms-block-1503253" class="tncms-block hidden-print"><div class="tnt-ads-container text-center  " >
        <div id="ad-1503253" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1503253');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1830313" class="tncms-block tnc-overlay"><div class="modal promo-designer-modal in centered " id="promo-designer-modal-custom-pop" tabindex="-1" role="dialog" aria-label="Promotional pop up" aria-hidden="true" >
        <div class="modal-dialog modal-md centered">
            <div class="modal-content">
                <div class="modal-body"><section id="block-1830313" class="block emphasis-h3   " ><div class="promo-design"><div class="card-bg-color rounded_rectangle">
        <div class="card-panel panel"><button type="button" class="close" data-dismiss="modal" aria-label="Close">
                <span class="tnt-stack" aria-hidden="true">
                    <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                    <i class="fas tnt-times-circle tnt-stack-1x"></i>
                </span>
            </button>
             <div class="panel-body">
                <div class="promo-designer-wrapper">
                    
                        <div class="headline large light text-shadow">
                            Support local journalism
                        </div>
                    
                    
                        <p class="text light text-shadow">
                            Now, more than ever, the world needs trustworthy reporting—but good journalism isn’t free. Please support us by making a contribution.
                        </p>
                    <div class="promo-design-button">
                            <a href="/contribute">
                                <button type="button" class="btn btn-danger btn-lg">Contribute</button>
                            </a>
                        </div>
                </div>   
            </div>
        </div>
    </div>
</div></section></div>
            </div>
        </div>
    </div></div><div id="tncms-block-1931568" class="tncms-block"><style>
.apg-alert-bw {
    background-color: #b2c5be;
    color: black;
    margin-left: 20px;
    margin-right:20px;
}


</style><div class="grid" style="padding-top: 20px;">
<div class="row visible-sm visible-xs hidden-md hidden-lg">
    <div class="alert apg-alert-bw" role="alert">
We've recently updated our online systems. If you can't login please try resetting your password. You must login with an email address. If you don't have an email associated with your account email 
<a href="mailto:circulation@idahopress.com" style="font-weight: bold;">circulation@idahopress.com</a> for help creating one. 
    </div>
</div>
</div></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1469104" class="tncms-block ad-spacer-bottom">
<div class='hidden-sm hidden-xs'>
<div class="tnt-ads-container text-center  " >
        <div id="ad-1469104" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1469104');
                        
                });
            </script>
        </div>
    </div>
</div>
<div class='hidden-lg hidden-md'>
<div class="tnt-ads-container text-center  " >
        <div id="ad-1469104_mobile" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1469104_mobile');
                        
                });
            </script>
        </div>
    </div>
</div>
</div></div></div>
        </div><div class="modal fullscreen" id="photo-carousel-83b21706-0a2a-5f94-bada-38346fdbe167" tabindex="-1" role="dialog" aria-labelledby="photo-carousel-83b21706-0a2a-5f94-bada-38346fdbe167" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-body">
                    <button type="button" class="close" data-dismiss="modal">
                        <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                        <span class="sr-only">Close</span>
                    </button>
                    
    <div id="carousel-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal" class="card photo-carousel   has-ad-unit  subscriber-hide letterbox-style-default">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal" class="carousel-inner"><div  class="item photo-10dba617-7a84-5368-a795-8e92ccdd44cd">
                            <div class="item-container">
				                <div data-track-object='{"title":"Things To Do","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/1/0d/10dba617-7a84-5368-a795-8e92ccdd44cd/5f35de544a5db.image.jpg?resize=1200%2C1022"
                    
                    alt="English garden"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1280"
                    height="1090"
                    data-src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/1/0d/10dba617-7a84-5368-a795-8e92ccdd44cd/5f35de544a5db.image.jpg?resize=1200%2C1022" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal" data-target=".caption-inner-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal collapse in"><div class="caption-text"><div class="subscriber-preview"><p>The English garden in bloom at Idaho Botanical Garden.</p></div></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">By Anna Lindquist</span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Fenglish-garden%2Fimage_10dba617-7a84-5368-a795-8e92ccdd44cd.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/english-garden/image_10dba617-7a84-5368-a795-8e92ccdd44cd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"10dba617-7a84-5368-a795-8e92ccdd44cd"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=English%20garden&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Fenglish-garden%2Fimage_10dba617-7a84-5368-a795-8e92ccdd44cd.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/english-garden/image_10dba617-7a84-5368-a795-8e92ccdd44cd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"10dba617-7a84-5368-a795-8e92ccdd44cd"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/english-garden/image_10dba617-7a84-5368-a795-8e92ccdd44cd.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/english-garden/image_10dba617-7a84-5368-a795-8e92ccdd44cd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"10dba617-7a84-5368-a795-8e92ccdd44cd"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/10dba617-7a84-5368-a795-8e92ccdd44cd" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"10dba617-7a84-5368-a795-8e92ccdd44cd"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20English%20garden&body=https%3A%2F%2Fwww.idahopress.com%2Fenglish-garden%2Fimage_10dba617-7a84-5368-a795-8e92ccdd44cd.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"10dba617-7a84-5368-a795-8e92ccdd44cd"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/english-garden/image_10dba617-7a84-5368-a795-8e92ccdd44cd.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"10dba617-7a84-5368-a795-8e92ccdd44cd"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-10dba617-7a84-5368-a795-8e92ccdd44cd-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="10dba617-7a84-5368-a795-8e92ccdd44cd" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="10dba617-7a84-5368-a795-8e92ccdd44cd" class="save-list-10dba617-7a84-5368-a795-8e92ccdd44cd-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="10dba617-7a84-5368-a795-8e92ccdd44cd" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-b20bcb57-c1f1-5b01-b644-3480c27cfc37">
                            <div class="item-container">
				                <div data-track-object='{"title":"Things To Do","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-vertical"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/b/20/b20bcb57-c1f1-5b01-b644-3480c27cfc37/60806462878b8.image.jpg?resize=1200%2C1601"
                    
                    alt="A couple dinosaurs on the Jurassic Quest"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1246"
                    height="1662"
                    data-src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/b/20/b20bcb57-c1f1-5b01-b644-3480c27cfc37/60806462878b8.image.jpg?resize=1200%2C1601" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal" data-target=".caption-inner-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal collapse in"><div class="caption-text"><div class="subscriber-preview"><p>The Jurassic Quest drive-thru event will be held at the Ford Idaho Center May 14-23.</p></div></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">Courtesy Jurassic Quest</span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Fa-couple-dinosaurs-on-the-jurassic-quest%2Fimage_b20bcb57-c1f1-5b01-b644-3480c27cfc37.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/a-couple-dinosaurs-on-the-jurassic-quest/image_b20bcb57-c1f1-5b01-b644-3480c27cfc37.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b20bcb57-c1f1-5b01-b644-3480c27cfc37"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=A%20couple%20dinosaurs%20on%20the%20Jurassic%20Quest&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Fa-couple-dinosaurs-on-the-jurassic-quest%2Fimage_b20bcb57-c1f1-5b01-b644-3480c27cfc37.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/a-couple-dinosaurs-on-the-jurassic-quest/image_b20bcb57-c1f1-5b01-b644-3480c27cfc37.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b20bcb57-c1f1-5b01-b644-3480c27cfc37"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/a-couple-dinosaurs-on-the-jurassic-quest/image_b20bcb57-c1f1-5b01-b644-3480c27cfc37.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/a-couple-dinosaurs-on-the-jurassic-quest/image_b20bcb57-c1f1-5b01-b644-3480c27cfc37.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b20bcb57-c1f1-5b01-b644-3480c27cfc37"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/b20bcb57-c1f1-5b01-b644-3480c27cfc37" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"b20bcb57-c1f1-5b01-b644-3480c27cfc37"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20A%20couple%20dinosaurs%20on%20the%20Jurassic%20Quest&body=https%3A%2F%2Fwww.idahopress.com%2Fa-couple-dinosaurs-on-the-jurassic-quest%2Fimage_b20bcb57-c1f1-5b01-b644-3480c27cfc37.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"b20bcb57-c1f1-5b01-b644-3480c27cfc37"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/a-couple-dinosaurs-on-the-jurassic-quest/image_b20bcb57-c1f1-5b01-b644-3480c27cfc37.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b20bcb57-c1f1-5b01-b644-3480c27cfc37"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-b20bcb57-c1f1-5b01-b644-3480c27cfc37-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="b20bcb57-c1f1-5b01-b644-3480c27cfc37" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="b20bcb57-c1f1-5b01-b644-3480c27cfc37" class="save-list-b20bcb57-c1f1-5b01-b644-3480c27cfc37-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="b20bcb57-c1f1-5b01-b644-3480c27cfc37" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </div>
    </div>
        <script>
            jQuery(document).ready(function($){
                $('#photo-carousel-83b21706-0a2a-5f94-bada-38346fdbe167').on('show.bs.modal', function(e){
                    $('#fixed-leaderboard-top-container').addClass('overlay-leaderboard');
                });
                $('#photo-carousel-83b21706-0a2a-5f94-bada-38346fdbe167').on('hide.bs.modal', function(e){
                    $('#fixed-leaderboard-top-container').removeClass('overlay-leaderboard');
                });
            });
        </script><article itemscope itemtype="https://schema.org/Article" id="asset-83b21706-0a2a-5f94-bada-38346fdbe167" class="asset article-default"  data-url="https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="Visit the Farmhouse Collective’s Summer Open Market June 4-5 "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/1/0d/10dba617-7a84-5368-a795-8e92ccdd44cd/5f35de544a5db.image.jpg?crop=1090%2C1090%2C95%2C0&resize=630%2C630&order=crop%2Cresize">
            <meta itemprop="width" content="630">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="idahopress.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html" />
    <div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Things To Do
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2021-05-18T00:15:00-06:00" class="tnt-date asset-date text-muted">
            May 18, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-05-18T00:15:00-06:00" class="tnt-date asset-date text-muted">39 min ago</time></li>
        
        
            <li class="hidden-print"><a href="/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html#comments" class="cm"><span class="fas tnt-comments"></span>
            <span class="sr-only">Comments</span>
        </a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-05-18T00:15:00-06:00">
    <meta itemprop="datePublished" content="2021-05-18T00:15:00-06:00">
    <meta itemprop="dateModified" content="2021-05-18T00:15:00-06:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Things%20To%20Do&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/83b21706-0a2a-5f94-bada-38346fdbe167" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20Things%20To%20Do&body=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-md-12"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div id="asset-photo-carousel">
    <div id="carousel-83b21706-0a2a-5f94-bada-38346fdbe167" class="card photo-carousel    subscriber-hide letterbox-style-default">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167" class="carousel-inner"><div  class="item photo-10dba617-7a84-5368-a795-8e92ccdd44cd">
                            <div class="item-container">
				                <div data-track-object='{"title":"Things To Do","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                            <a href="#1" data-photo-target=".photo-10dba617-7a84-5368-a795-8e92ccdd44cd" data-instance="#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal" data-target="#photo-carousel-83b21706-0a2a-5f94-bada-38346fdbe167" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1280">
            <meta itemprop="height" content="1090">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/1/0d/10dba617-7a84-5368-a795-8e92ccdd44cd/5f35de544a5db.image.jpg?resize=1200%2C1022">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/1/0d/10dba617-7a84-5368-a795-8e92ccdd44cd/5f35de544a5db.image.jpg?resize=1200%2C1022">
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/1/0d/10dba617-7a84-5368-a795-8e92ccdd44cd/5f35de544a5db.image.jpg?resize=1200%2C1022"
                    
                    alt="English garden"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1280"
                    height="1090"
                    data-src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/1/0d/10dba617-7a84-5368-a795-8e92ccdd44cd/5f35de544a5db.image.jpg?resize=1200%2C1022" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-83b21706-0a2a-5f94-bada-38346fdbe167 collapse in"><div class="caption-text"><div class="subscriber-preview"><p>The English garden in bloom at Idaho Botanical Garden.</p></div></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">By Anna Lindquist</span></li>
                                    
                                
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-b20bcb57-c1f1-5b01-b644-3480c27cfc37">
                            <div class="item-container">
				                <div data-track-object='{"title":"Things To Do","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-vertical"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                            <a href="#2" data-photo-target=".photo-b20bcb57-c1f1-5b01-b644-3480c27cfc37" data-instance="#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal" data-target="#photo-carousel-83b21706-0a2a-5f94-bada-38346fdbe167" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1246">
            <meta itemprop="height" content="1662">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/b/20/b20bcb57-c1f1-5b01-b644-3480c27cfc37/60806462878b8.image.jpg?resize=1200%2C1601">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/b/20/b20bcb57-c1f1-5b01-b644-3480c27cfc37/60806462878b8.image.jpg?resize=1200%2C1601">
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/b/20/b20bcb57-c1f1-5b01-b644-3480c27cfc37/60806462878b8.image.jpg?resize=1200%2C1601"
                    
                    alt="A couple dinosaurs on the Jurassic Quest"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1246"
                    height="1662"
                    data-src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/b/20/b20bcb57-c1f1-5b01-b644-3480c27cfc37/60806462878b8.image.jpg?resize=1200%2C1601" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-83b21706-0a2a-5f94-bada-38346fdbe167 collapse in"><div class="caption-text"><div class="subscriber-preview"><p>The Jurassic Quest drive-thru event will be held at the Ford Idaho Center May 14-23.</p></div></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">Courtesy Jurassic Quest</span></li>
                                    
                                
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"><div id="tncms-block-1721160" class="tncms-block"><div align="center">
      <table style="background-color: #E6E6E6;
                    width: 90%; border-radius:5px"><tbody><tr><td>
              <div class="emailSignupSpan" style="color:white; padding:10px" align="center">
                <h1 style="color: black;
                           font-weight: 600;">
                  Support Local Journalism </h1>
              </div>
              <center><label for="ssOffer" style="color:black; 
                		  padding:0px
                			font-weight: 100;
											font-size: 18px;"> 
                If you value these stories, please consider subscribing.
                </label></center>
            </td>
            <td width="25%" valign="middle">
              <p><br><a href="/subscribe" text-decoration="none"><font style="font-family: verdana;
									font-weight: 900;
                  font-size: 25px;
									line-height: 20px;
                  color: white;
									background-color:#FF6600;
                  border:  10px solid #FF6600;
									border-radius: 15px;
                  box-shadow: 2px 3px  5px #888888;                                                            text-decoration: none;
             			width:250px;"> Subscribe</font></a></p>
            </td>
          </tr></tbody></table></div>
    <p><br></p></div></div>

            <div id="asset-content" data-asset-uuid="83b21706-0a2a-5f94-bada-38346fdbe167" data-smart-adunit="/94837440/nampa/ipt/townnews/commerce">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                            
                            <div id="share-left-affix" class="share-container content-left hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Things%20To%20Do&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/83b21706-0a2a-5f94-bada-38346fdbe167" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20Things%20To%20Do&body=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-83b21706-0a2a-5f94-bada-38346fdbe167-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="83b21706-0a2a-5f94-bada-38346fdbe167" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="83b21706-0a2a-5f94-bada-38346fdbe167" class="save-list-83b21706-0a2a-5f94-bada-38346fdbe167-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="83b21706-0a2a-5f94-bada-38346fdbe167" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        
                        <div class="asset-body has-fixed-share" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above visible-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Things%20To%20Do&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/83b21706-0a2a-5f94-bada-38346fdbe167" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20Things%20To%20Do&body=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-83b21706-0a2a-5f94-bada-38346fdbe167-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="83b21706-0a2a-5f94-bada-38346fdbe167" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="83b21706-0a2a-5f94-bada-38346fdbe167" class="save-list-83b21706-0a2a-5f94-bada-38346fdbe167-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="83b21706-0a2a-5f94-bada-38346fdbe167" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p><strong>Visit the Farmhouse Collective’s Summer Open Market June 4-5</strong></p></div><div class="subscriber-preview"><p>At the Farmhouse has announced The Farmhouse Collective&rsquo;s Summer Open Market Friday, June 4 from 4-8 p.m. and Saturday, June 5 10 a.m. to 4 p.m. on the Bachman Family Ranch, 30631 Hot Springs Road in Bruneau, Idaho. The event will feature live music and food and beverages while browsing vintage and handmade goods from local vendors at this pop-up market in the meadow. The full list of hand-picked vendors and live art workshop details will be updated on the At the Farmhouse website: <a href="http://atthefarmhouse.com/pages/events">atthefarmhouse.com/pages/events</a>.</p></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>Parking is available on one side of the pasture and the market is hosted on the other. Masks are not required but a personal option. Porta toilets, handwashing stations and hand sanitizer will be available onsite throughout the event. General admission is $7 for one day or $10 for both days. Tickets are available online through Eventbrite and at the gate: <a href="http://eventbrite.com/e/farmhouse-collective-summer-open-meadow-market-tickets-151892479495">eventbrite.com/e/farmhouse-collective-summer-open-meadow-market-tickets-151892479495</a>. More information is also available via Facebook.</p></div><div class="subscriber-only"><p><strong>The Idaho Botanical Garden to host Create and Connect</strong></p></div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"><div id="tncms-block-1721694" class="tncms-block"><style>
      .signup-wrapper {
      margin: 0 -10px 12px -15px;
      display:flex;
      }
    .signup-wrapper *{
    color:white;
    font-weight:bold;
    padding-left: 12px;
    } 
      .signup-wrapper input{
      color:#343434;
      }
    
    </style><div class="signup-wrapper">
      <div style="background-color:#343434">
        <div class="row">
	        <h4 style="color:white; text-align:left; font-weight:bold;">
                     Do you LOVE local news? Get Local News Headlines in your inbox daily.
 	        </h4>
        </div>
        
        
          <div class="row" id="emailSignupForm" style="display:;">
               <div class="col-xs-8">
                  <input class="form-control" id="ssEmail" placeholder="Enter your email" type="email"></div>
            <div class="col-xs-4"> <button class="btn btn-primary pull-left" id="emailSignupFormButton" onclick="emailSignupSubmit();" style="width: 90%">  Yes!  </button>
            </div>
          <label for="ssOffer" class="col-xs-12"> <input checked id="ssOffer" name="ssOffer" type="checkbox"><small>Include special offer
            &amp; contest announcement emails</small> </label> 
        </div>
          <div class="row" id="emailSignUpComplete" style="display:none">
            <div class="col-xs-12">
              <div>
                <div>
                  <div class="emailSignupSpan"> Thanks! You'll start receiving
                    the headlines tomorrow! 
                  </div>
                </div>
              </div>
            </div>
          </div>
        </div>
     </div></div></div>
     <!-- search-2020-04-02-secondstreet-signup --> 
    
    
    
        <style>
        .emailSignup {
            margin: 0 -15px 12px -15px;
            padding: 12px 18px;
            background-color: #343434;
            color: white;
        }
        .emailSignupSpan {
            font-weight:bold;
            padding: 6px 0;
        }
        </style>
        <!--<div class="emailSignup"> test by Kalenn

            <div id="emailSignupPrompt" style="display: block;">
                <div style="display:inline-block;width:75%;vertical-align:top;">
                    <div class="emailSignupSpan">
                        Want more news like this in your email inbox every morning?
                    </div>
                </div><div style="display:inline-block;width:25%;vertical-align:top;">
                    <div class="btn btn-primary pull-right" id="emailSignupPromptButton" onclick="emailSignupPrompt();">
                        Yes!
                    </div>
                </div>
            </div>
            <div id="emailSignupForm" class="form-inline" style="display: none;">
                <div style="display:inline-block;width:75%;vertical-align:top;">
                    <input class="form-control" id="ssEmail" placeholder="Enter your email" style="width:100%" type="email"> <label for="ssOffer"><input checked id="ssOffer" name="ssOffer" type="checkbox"> Include special offer &amp; contest announcement emails</label>
                </div><div style="display:inline-block;width:25%;vertical-align:top;">
                    <div class="btn btn-primary pull-right" id="emailSignupFormButton" onclick="emailSignupSubmit(&quot;test&quot;);">
                        Sign up
                    </div>
                </div>
            </div>
            <div id="emailSignUpComplete" style="display:none;">
                <div style="display:inline-block;width:100%;vertical-align:top;">
                    <div class="emailSignupSpan">
                        Thanks! You'll start receiving the headlines tomorrow!
                    </div>
                </div>
            </div>
        
        </div>-->
    

<div class="subscriber-only"><p>The Idaho Botanical Garden has organized a fundraiser event — Create and Connect — to help support the Garden’s programs and plants. Tickets include live music and performance, local food (by Horsewood Catering) and drinks to enjoy while trying out DIY kits and other projects 6–9 p.m. June 19. The event will also feature a live auction onsite and a digital auction (June 11 – 20). Picnic gear is welcome.</p></div><div class="subscriber-only"><p><strong>Jurassic Quest continues through May 23</strong></p></div><div class="subscriber-only"><p>Jurassic Quest features over 70 photorealistic dinosaurs in a drive-thru exhibit at Ford Idaho Center, 16114 N. Idaho Center Blvd. Tickets are $49 per vehicle of eight people or less and are available now through <a href="http://jurassicquest.com">jurassicquest.com</a>.</p></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    
        
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Things%20To%20Do&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/83b21706-0a2a-5f94-bada-38346fdbe167" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20Things%20To%20Do&body=https%3A%2F%2Fwww.idahopress.com%2Ftownnews%2Fcommerce%2Fthings-to-do%2Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/townnews/commerce/things-to-do/article_83b21706-0a2a-5f94-bada-38346fdbe167.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"83b21706-0a2a-5f94-bada-38346fdbe167"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-83b21706-0a2a-5f94-bada-38346fdbe167-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="83b21706-0a2a-5f94-bada-38346fdbe167" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="83b21706-0a2a-5f94-bada-38346fdbe167" class="save-list-83b21706-0a2a-5f94-bada-38346fdbe167-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="83b21706-0a2a-5f94-bada-38346fdbe167" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22ticket%22#tncms-source=keyword" class="tag-ticket label label-default" data-tncms-track-dmp='search: ticket'>Ticket</a>
            </li> <li>
                <a href="/search/?k=%22open%20market%22#tncms-source=keyword" class="tag-open-market label label-default" data-tncms-track-dmp='search: open-market'>Open Market</a>
            </li> <li>
                <a href="/search/?k=%22farmhouse%20collective%22#tncms-source=keyword" class="tag-farmhouse-collective label label-default" data-tncms-track-dmp='search: farmhouse-collective'>Farmhouse Collective</a>
            </li> <li>
                <a href="/search/?k=%22food%22#tncms-source=keyword" class="tag-food label label-default" data-tncms-track-dmp='search: food'>Food</a>
            </li> <li>
                <a href="/search/?k=%22commerce%22#tncms-source=keyword" class="tag-commerce label label-default" data-tncms-track-dmp='search: commerce'>Commerce</a>
            </li> <li>
                <a href="/search/?k=%22economics%22#tncms-source=keyword" class="tag-economics label label-default" data-tncms-track-dmp='search: economics'>Economics</a>
            </li> <li>
                <a href="/search/?k=%22internet%22#tncms-source=keyword" class="tag-internet label label-default" data-tncms-track-dmp='search: internet'>Internet</a>
            </li> <li>
                <a href="/search/?k=%22auction%22#tncms-source=keyword" class="tag-auction label label-default" data-tncms-track-dmp='search: auction'>Auction</a>
            </li> <li>
                <a href="/search/?k=%22jurassic%22#tncms-source=keyword" class="tag-jurassic label label-default" data-tncms-track-dmp='search: jurassic'>Jurassic</a>
            </li> <li>
                <a href="/search/?k=%22vendor%22#tncms-source=keyword" class="tag-vendor label label-default" data-tncms-track-dmp='search: vendor'>Vendor</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1907209" class="tncms-block apg-margin-bottom-10">
        <div class='s2nPlayer k-ARYJ3bDx not-logged-in' data-type='float'></div><script type='text/javascript' src='//embed.sendtonews.com/player3/embedcode.js?fk=ARYJ3bDx&cid=10531&offsetx=0&offsety=100&floatwidth=400&floatposition=bottom-left' data-type='s2nScript'></script>
    </div><div id="tncms-block-1968529" class="tncms-block"><section id="block-1968529" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1968529 ">
        <div class="block-title-inner">
            <h3>
                
                Recommended for you
                
            </h3>
        </div>
    </div></div><div id="card-grid-behavioral-1968529" class="card-grid-behavioral card-grid card-img- card-compact"  data-lotame-track="true"><div class=" row equal equal-wrap"><div id="tncms-recommendations-1968529" class="recommendations-container"></div>
            <div class="clearfix hidden-xs"></div>
            </div>
        </div></section></div></div>

                    <div class="asset-comments hidden-print"><a id="comments-collapsible-toggle" class="btn btn-block btn-lg btn-default"><i class="fas tnt-sync"></i> Load comments</a><div id="comments-collapsible" class="comments-container-collapsible collapsed">
                
                <div id="comments-container" class="comments-container">
                    
                    <div
                        id="comments" 
                        class="fb-comments" 
                        data-href="http://www.idahopress.com/tncms/asset/editorial/83b21706-0a2a-5f94-bada-38346fdbe167/" 
                        data-num-posts="10" 
                        data-width="100%" 
                    ></div>
                    <style>
                        .fb_iframe_widget,
                        .fb_iframe_widget span,
                        .fb_iframe_widget span iframe[style]{
                            min-width:100%!important;
                            width:100%!important;
                        }
                    </style>
                </div>
            
        </div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"><div id="tncms-block-1879920" class="tncms-block"></div></div></div>
            </div>

            

            </div>
        </div></div>
</article><template class="hidden" id="infinity-asset-top">  
            <div id="tncms-region-infinity_asset_top" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-first">
            <div id="tncms-region-infinity_asset_after_first" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-third">
            <div id="tncms-region-infinity_asset_after_third" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-fifth">
            <div id="tncms-region-infinity_asset_after_fifth" class="tncms-region "></div>
        </template>
        <template class="hidden" id="infinity-asset-after-eighth">
            <div id="tncms-region-infinity_asset_after_eighth" class="tncms-region "></div>
        </template>

    <div id="infinite-container" class="infinity-summary-container hidden-print">
        <div id="infinite-more" data-next-url="https://www.idahopress.com/tncms/search/mlt/?origin=83b21706-0a2a-5f94-bada-38346fdbe167&app=editorial&inline=infinity&type=article%2Ccollection%2Cvideo%2Cyoutube">
            <i class="fas tnt-spinner tnt-pulse"></i>
        </div>
    </div>

    <script>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</script>
    
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
    

            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1492197" class="tncms-block"><style>
	#tncms-block-1492197 {
		display: none;
		position: fixed;
		bottom: 0;
		z-index: 300;
		left: 50%;
		-webkit-transform: translateX(-50%);
		   -moz-transform: translateX(-50%);
			-ms-transform: translateX(-50%);
				transform: translateX(-50%);
		width: 100%;
		max-width: 900px;
	}
	#block-1492197 .block-title  {
		display: none;
	}
	.clearFix {
		clear: both;
	}
	.fop_promo {

	}
	.fop_heading {
		background-color: #72271d;
		color: #ffffff;
		padding: 12px 24px;
		font-size: 16px;
		line-height: 24px;
		position: relative;
	}
	.fop_offerShort {
		float: left;
		padding-right: 24px;
	}
	.fop_login {
		float: right;
		padding-right: 36px;
		font-size: 14px;
	}
	.fop_login a {
		color: #ffffff;
		text-decoration: none;
	}
	.fop_login a:hover {
		color: #ffffff;
		text-decoration: underline;
	}
	.fop_close {
		position: absolute;
		top: 12px;
		right: 12px;
		width: 24px;
		height: 24px;
		text-align: center;
		font-size: 16px;
		cursor: pointer;
	}
	.fop_body {
		background-color: #f0f0f0;
		color: #222222;
		border-left: 1px solid rgba(0,0,0,0.25);
		border-right: 1px solid rgba(0,0,0,0.25);
		max-height: 0;
		-webkit-transition: all 300ms ease;
		transition: all 300ms ease;
	}
	#block-1492197:hover .fop_body {
		max-height: 1000px;
		border-bottom: 1px solid rgba(0,0,0,0.25);
	}
	.fop_body > div {
		display: inline-block;
		width: 33.333%;
		vertical-align: middle;
		padding: 24px 24px;
	}
	.fop_logo {
		text-align: center;
	}
	.fop_logo img {
		margin: 0 auto;
	}
	.fop_tagline {
		text-align: center;
		font-size: 16px;
		line-height: 24px;
	}
	.fop_offerLong {
		text-align: center;
	}
	.fop_offerLong .fop_offerText {
		text-align: left;
		margin-bottom: 12px;
	}
	.fop_offerLong .fop_offerLink {
		margin: 0 auto;
		border: 1px solid #72271d;
		background-color: #72271d;
		color: #ffffff;
		display:inline-block;
		padding:6px 15px;
		cursor: pointer;
		-webkit-transition: all 200ms ease;
		transition: all 200ms ease;
	}
	.fop_offerLink:hover {
		background-color: #ffffff;
		color: #72271d;
		display:inline-block;
		padding:6px 15px;
		text-decoration: none;
	}
	.fop_offerLink:hover a {
		text-decoration: none;
	}
	@media screen and (max-width: 750px) {
		.fop_body > div {
			width: 100%;
			padding: 12px 24px;
		}
		.fop_body {
			padding: 0px 0px;
		}
		#block-1492197:hover .fop_body {
			padding: 12px 0px;
		}
		.fop_offerLong .fop_offerText {
			text-align: center;
		}
	}
</style>
<script>
(function($) {
$(function() {
	var thisBlock = $('#tncms-block-1492197');
	var thisBlockClose = $('#tncms-block-1492197 .fop_close');
	var urSet = $.cookie('tncms-services');
	var fopNo = $.cookie('fop_no');
	// user closed promo
	thisBlockClose.click(function(){
		thisBlock.css('display','none');
		$.cookie('fop_no', 1, { path: '/', expires: 7 });
	});
	// user is logged in or has previously closed promo
	if( ( urSet && urSet != '' ) || ( fopNo && fopNo != '' ) ) {
		thisBlock.css('display','none');
	} else {
		thisBlock.css('display','block');
	}
})
})(jQuery);
</script><section id="block-1492197" class="block emphasis- #222222 heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1492197 #ffffff">
        <div class="block-title-inner">
            <h2>
                
                Footer Offer Promo
                
            </h2>
        </div>
    </div></div><div class="fop_promo invalid-subscribers-only">
	<div class="fop_heading">
		<div class="fop_offerShort">Join now to get home delivery for as low as $10/month, any way you want it!</div>
		<div class="fop_login">Already a member? <a href="https://www.idahopress.com/users/login/">Login Here</a></div>
		<div class="fop_close"><i class="fas tnt-times" aria-hidden="true"></i></div>
		<div class="clearFix"></div>
	</div>
	<div class="fop_body">
		<div class="fop_logo"><img class="media-object img-responsive " src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/2802b32e-641e-11e8-acee-4b19619b1320.png" alt=""></div><div class="fop_tagline">Local News Worth Holding
		</div><div class="fop_offerLong">
			<div class="fop_offerText">Sign up for a new subscription today and get home delivery or digital-only access for only $10/month!.</div>
			<a href="/subscriptions/" class="fop_offerLink">Join Today!</a>
		</div>
	</div>
</div></section></div><div id="tncms-block-1598809" class="tncms-block">
<div class="footerContainer-1598809 footerContainer footer-upper hidden-sm">
        <div class="cols-wrap">
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/" style="color:#fff;">News</a></li>
                <li class="col-item"><a href="/" title="Idaho Press">Idaho Press</a></li><li class="col-item"><a href="/boiseweekly" title="Boise Weekly">Boise Weekly</a></li><li class="col-item"><a href="/kuna" title="Kuna Melba News">Kuna Melba News</a></li><li class="col-item"><a href="/meridian" title="Meridian Press">Meridian Press</a></li><li class="col-item"><a href="/emmett" title="Messenger-Index">Messenger-Index</a></li><li class="col-item"><a href="/blueturfsports" title="Blue Turf Sports">Blue Turf Sports</a></li><li class="col-item"><a href="/eyeonboise" title="Eye On Boise">Eye On Boise</a></li><li class="col-item"><a href="http://www.postregister.com/farmandranch" target="_blank" title="Farm & Ranch">Farm & Ranch</a></li><li class="col-item"><a href="/eedition/" target="" title="E-Edition">E-Edition</a></li><li class="col-item"><a href="/classifieds/" target="" title="Classifieds">Classifieds</a></li><li class="col-item"><a href="/obituaries/" target="" title="Obituaries">Obituaries</a></li><li class="col-item"><a href="/subscribe/" target="" title="Subscribe Today">Subscribe Today</a></li><li class="col-item"><a href="/local-events/" target="" title="Local Events">Local Events</a></li></ul>
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/site/services/" style="color:#fff;">Services</a></li><li class="col-item"><a href="/site/advertising" target="" title="Advertising">Advertising</a></li><li class="col-item"><a href="/site/nie" target="" title="Newspapers In Education">Newspapers In Education</a></li><li class="col-item"><a href="/place-an-ad" target="_blank" title="Place a Classified Ad">Place a Classified Ad</a></li><li class="col-item"><a href="https://new.evvnt.com/?with_navbar&force_snap_sell&partner=IDAHOPRESS&publisher_url:idahopress.com#/quick" target="_blank" title="Promote Your Event">Promote Your Event</a></li><li class="col-item"><a href="/site/forms/subscription_services/deliveryissue/delivery_issues/" target="" title="Report Delivery Issue">Report Delivery Issue</a></li><li class="col-item"><a href="https://www.idahopress.com/users/admin/?newzware=1" target="_blank" title="Manage Your Subscription">Manage Your Subscription</a></li><li class="col-item"><a href="https://www.idahopress.com/stimulus/" target="" title="Stimulus">Stimulus</a></li></ul>
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/site/forms/online_services/submit_news/" style="color:#fff;">Submissions</a></li><li class="col-item"><a href="/site/forms/online_services/submit_news" target="" title="Submit News">Submit News</a></li><li class="col-item"><a href="mailto:legals@idahopress.com" target="" title="Submit Legal Notices to legals@idahopress.com or call 208-465-8129">Submit Legal Notices to legals@idahopress.com or call 208-465-8129</a></li><li class="col-item"><a href="/site/forms/online_services/submit_sports" target="" title="Report Sports Scores/Stats">Report Sports Scores/Stats</a></li><li class="col-item"><a href="/site/forms/online_services/submit_cheer" target="" title="Submit a Cheers &amp; Jeers">Submit a Cheers &amp; Jeers</a></li><li class="col-item"><a href="/site/forms/online_services/letter" target="" title="Send a Letter to the Editor">Send a Letter to the Editor</a></li><li class="col-item"><a href="/site/forms/online_services/guest_opinion" target="" title="Submit a Guest Opinion">Submit a Guest Opinion</a></li><li class="col-item"><a href="http://selfserve.idahopress.com/" target="" title="Submit an Obituary">Submit an Obituary</a></li><li class="col-item"><a href="/site/forms/announcements/anniversary/" target="" title="Anniversary Announcement">Anniversary Announcement</a></li><li class="col-item"><a href="/site/forms/announcements/birth/" target="" title="Birthday Announcement">Birthday Announcement</a></li><li class="col-item"><a href="/site/forms/announcements/engagement/" target="" title="Engagement Announcement">Engagement Announcement</a></li><li class="col-item"><a href="/site/forms/announcements/wedding/" target="" title="Wedding Announcement">Wedding Announcement</a></li><li class="col-item"><a href="/site/forms/announcements/retirement/" target="" title="Retirement Announcement">Retirement Announcement</a></li><li class="col-item"><a href="/site/forms/online_services/webissue/" target="" title="Website Issues">Website Issues</a></li><li class="col-item"><a href="https://www.idahopress.com/community/holiday-bazaar/" target="" title="Holiday Bazaar Blast">Holiday Bazaar Blast</a></li></ul>
            <div class="footer-col footer-col-info col-md-3 col-sm-6 col-xs-12">
                <div class="footer-col-info-basic">
                    <div class="col-heading"><a href="/site/contact/" style="color:#fff;">Contact Us</a></div>
                    
                    <div class="col-item col-item-highlight">Idaho Press</div>
                    <div class="col-item"><a href="http://maps.google.com/maps?daddr=1618+N+Midland+Blvd+Nampa,+ID+83651" target="_blank">1618 N Midland Blvd<br>Nampa, ID 83651</a></div>
                    <div class="col-item"><a href="tel:2084679251">208-467-9251</a></div>
                    <div class="col-item"><a href="mailto:newsroom@idahopress.com">newsroom@idahopress.com</a></div><li class="col-item"><a href="/site/contact" target="" title="Contact Us">Contact Us</a></li><li class="col-item"><a href="/site/about" target="" title="About Us">About Us</a></li><li class="col-item"><a href="/site/staff" target="" title="Staff">Staff</a></li></div>
                <div class="footer-col-info-social">
                    <div class="col-heading">Follow Us</div><div class="col-item-icon"><a href="https://www.facebook.com/Idaho.Press" target="_blank" title="Facebook"><span class="fab tnt-facebook-f"></span></a></div><div class="col-item-icon"><a href="https://twitter.com/theIdahoPress" target="_blank" title="Twitter"><span class="fab tnt-twitter"></span></a></div><div class="col-item-icon"><a href="https://www.linkedin.com/company/103648" target="_blank" title="Linkedin"><span class="fab tnt-linkedin-in"></span></a></div><div class="col-item-icon"><a href="https://www.youtube.com/user/idahopresstribune" target="_blank" title="YouTube"><span class="fab tnt-youtube"></span></a></div><div class="col-item-icon"><a href="https://www.instagram.com/idahopress/" target="_blank" title="Instagram"><span class="fab tnt-instagram"></span></a></div></div>
                <div class="footer-col-info-social" style="margin-top:15px;">
                    <li class="col-heading"><a href="/getthepaper/" style="color:#fff;">Get The Paper</a></li>
                    <div class="col-item"><a href="/getthepaper">Find the nearest store/rack location to pick up a copy.</a></div>
                </div>
            </div>
            <div style="clear:both;"></div>
        </div>
    </div></div><div id="tncms-block-1505608" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1505608">
        <div class="col-md-12"><small>&copy; Copyright 2021 <a href="/">Idaho Press</a>, 1618 N. Midland Blvd. Nampa, ID</small><small>&nbsp;| <a href="/site/terms.html">Terms&nbsp;of&nbsp;Service</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy&nbsp;Policy</a></small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            <div id="blox-message-incompatible" class="notification wall alert alert-dismissable alert-warning hidden-print" data-message="blox ad blocker">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <h4 class="clearfix meter-heading  media-heading row">
            Ads are being blocked by your browser.
        </h4>
        <p><strong>Please</strong> disable your ad blocker, whitelist our site, or <a class="alert-link" href="/subscriptions/?referer_url=https%253A%252F%252Fwww.idahopress.com%252Ftownnews%252Fcommerce%252Fthings-to-do%252Farticle_83b21706-0a2a-5f94-bada-38346fdbe167.html">purchase a subscription</a></p>
    </div>
</template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("83b21706-0a2a-5f94-bada-38346fdbe167")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc9940.add('act', dmpData);_cc9940.bcp();
            });
        });
    
    </script>
    
    
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/png_core/resources/scripts/png.js?_dc=1608190854"></script>
<script src="//os4m-d.openx.net/w/1.0/jstag?nc=94837440-PNG_Bidder"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/scripts/main.js?_dc=1565291251"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/scripts/jquery.matchHeight.js?_dc=1513711533"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/scripts/incognitoChecker.js?_dc=1517351390"></script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.google.survey.f62819b485e5f0a32cee78210d157aca.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.c449e572860e4381a13b08f9d39ce5be.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.granted.697bbb21056c63b56789e404bb4fa8a7.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.denied.63a83f5bb281eac870c3c9e1091b2729.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.8c58f9d9e2edecca6a7b394f47f1507e.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/promo_popup.fe40d77fce691e6ed54cb520a782a693.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.66c591eb93f177b0f59892f361c3b1b4.js"></script>
<script>/*<![CDATA[*/ 
                jQuery(document).ready(function($) {
            
                var gallery_ad_83b21706_0a2a_5f94_bada_38346fdbe167_photo_modal = false;
                var gallery_changed_83b21706_0a2a_5f94_bada_38346fdbe167_photo_modal = false;
                var sUrl =  window.location.href,
                        sUuid = sUrl.split("_").pop(),
                        sId = sUuid.substring(0, sUuid.indexOf('.')),
                        aInlineImages = document.querySelectorAll('.inline-image .image, .inline-image .expand');
                     for (i = 0; i < aInlineImages.length; ++i) {
                        var oImage = aInlineImages[i],
                            sInstance = oImage.getAttribute('data-instance'),
                            sTarget = oImage.getAttribute('data-target');
                        if (!oImage.classList.contains("tnt-asset-presentation-infographic")) {
	                        if (sInstance != null && sTarget != null){
	                            if (!sInstance.includes(sId)){
	                                oImage.setAttribute('data-instance', '#gallery-items-' + sId + '-photo-modal');
	                            }
	                            if (!sTarget.includes(sId)){
	                                oImage.setAttribute('data-target', '#photo-carousel-' + sId);
	                            }
	                        }
                        }
                     }
                $('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal .owl-stage-outer").height( $('#carousel-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        

                        
                            var currItem = $('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_83b21706_0a2a_5f94_bada_38346fdbe167_photo_modal = $('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal').data('owlCarousel');
                $('#carousel-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_83b21706_0a2a_5f94_bada_38346fdbe167_photo_modal.prev();
                });
                $('#carousel-83b21706-0a2a-5f94-bada-38346fdbe167-photo-modal .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_83b21706_0a2a_5f94_bada_38346fdbe167_photo_modal.next();
                });
            }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                // open photo modal
                jQuery(document).ready(function($){
                    $('[data-photo-target]').on('click', function(e){
                        e.preventDefault();
                        var item_target = $(this).data('target');
                        // get item index
                        var item_index = $(item_target +' '+$(this).data('photo-target')).parent().index();
                        // get current instance of carousel
                        var carousel_instance = $(this).data('instance');
                        var carousel_instance_data = $(carousel_instance).data('owlCarousel');
                        // fix non explict widths at viewports less than 900.
                        if(carousel_instance_data.width() < 320 & carousel_instance_data.viewport() < 900){
                            carousel_instance_data.onThrottledResize();
                        }
                        // load item from index
                        carousel_instance_data.to(item_index, 100, true);
                        // open modal
                        $(item_target).modal({'show':true});
                        __tnt.trackEvent({'category':'tnt-lightbox','action':'carousel-open', 'label':'article', 'value':'1'});
                        return false;
                    });
                    $('.photo-carousel-caption-toggle').on(__tnt.client.clickEvent, function(e){
                        var item_instance = $(this).data('instance');
                        $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon', $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon') == 'minus-circle' ? 'plus-circle' : 'minus-circle');
                    });
                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                jQuery(document).ready(function($) {
            
                var gallery_ad_83b21706_0a2a_5f94_bada_38346fdbe167 = false;
                var gallery_changed_83b21706_0a2a_5f94_bada_38346fdbe167 = false;
                var sUrl =  window.location.href,
                        sUuid = sUrl.split("_").pop(),
                        sId = sUuid.substring(0, sUuid.indexOf('.')),
                        aInlineImages = document.querySelectorAll('.inline-image .image, .inline-image .expand');
                     for (i = 0; i < aInlineImages.length; ++i) {
                        var oImage = aInlineImages[i],
                            sInstance = oImage.getAttribute('data-instance'),
                            sTarget = oImage.getAttribute('data-target');
                        if (!oImage.classList.contains("tnt-asset-presentation-infographic")) {
	                        if (sInstance != null && sTarget != null){
	                            if (!sInstance.includes(sId)){
	                                oImage.setAttribute('data-instance', '#gallery-items-' + sId + '-photo-modal');
	                            }
	                            if (!sTarget.includes(sId)){
	                                oImage.setAttribute('data-target', '#photo-carousel-' + sId);
	                            }
	                        }
                        }
                     }
                $('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167 .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167 .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167 .owl-stage-outer").height( $('#carousel-83b21706-0a2a-5f94-bada-38346fdbe167 .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        

                        
                            var currItem = $('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167 .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-83b21706-0a2a-5f94-bada-38346fdbe167 .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-83b21706-0a2a-5f94-bada-38346fdbe167 .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_83b21706_0a2a_5f94_bada_38346fdbe167 = $('#gallery-items-83b21706-0a2a-5f94-bada-38346fdbe167').data('owlCarousel');
                $('#carousel-83b21706-0a2a-5f94-bada-38346fdbe167 .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_83b21706_0a2a_5f94_bada_38346fdbe167.prev();
                });
                $('#carousel-83b21706-0a2a-5f94-bada-38346fdbe167 .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_83b21706_0a2a_5f94_bada_38346fdbe167.next();
                });
            }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/withinviewport.1f94ee79a22e6ee8e9c0bb61dec9999b.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.withinviewport.6ef0fee1774e9b313c264a5736522e35.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.scrollstop.934c2bd4d6bebe0494bcb9dd4b1b6ca1.js"></script>
<script>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</script>
<script>/*<![CDATA[*/ $("#comments-collapsible-toggle").click(function() { $("#comments-collapsible, #comments-collapsible-toggle").toggleClass("collapsed"); }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc9940.add('act', serviceData);_cc9940.bcp();
                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc9940.add('act', dmpData);_cc9940.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>