
  















<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.idahopress.com/content/tncms/live/" />
<meta name="keywords" content="jason dodd, school, major, national honors society, future, jessica miceli, study, state university" />
<meta name="news_keywords" content="jason dodd, school, major, national honors society, future, jessica miceli, study, state university" />
<meta name="description" content="School: Rocky Mountain High School" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=0, shrink-to-fit=no" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=501121541" />
<meta name="google-play-app" content="app-id=com.idahopress.android" />
<meta name="google-site-verification" content="wqsuraTJBaQlohvgtIInvOQuZSn9xBbFYtr2miWsnTU" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/f/4c/f4c2a60b-1a56-5732-ad48-95d2635c6d61/5edbba24548c8.image.jpg?crop=1247%2C1247%2C0%2C208&amp;resize=630%2C630&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="630" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Dodd, Sienna" />
<meta property="og:description" content="School: Rocky Mountain High School" />
<meta property="og:site_name" content="Idaho Press" />
<meta property="og:section" content="Rocky Mountain High School" />
<meta property="fb:app_id" content="2959550254137794" />
<meta property="article:publisher" content="http://www.facebook.com/Idaho.Press.Tribune" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@theidahopress" />
<meta name="twitter:image:alt" content="Dodd, Sienna" />
<meta property="fb:pages" content="101360505199" />
<meta property="tncms:ads" content="smart" />
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/png_core/resources/styles/png.css?_dc=1588962133"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.242df435c56456bcb15dfd4bd0d04199.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/global/resources/styles/site.css?_dc=1585690676"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/global/resources/styles/graduations.css?_dc=1588368461"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,400i,700,700i|Raleway:700,700i,900,900i"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/styles/site.css?_dc=1587499785"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<style>/*<![CDATA[*/ #user-controls-1506245 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1506245 .tn-user-screenname, #user-controls-1506245 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1506245 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1506245 .dropdown-signup { font-size: 12px; } #user-controls-1506245 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1506245 .large-user-avatar { margin-right: 10px; } #user-controls-1506245 .large-user-controls { font-size: 12px; } #user-controls-1506245 .logout-btn { cursor: pointer; } #user-controls-1506245 .user-welcome { color: #ffffff; } #user-controls-1506245 .login-btn { color: #fff!important; } #block-1268830 .search-spinner { position: absolute; } #block-1268830 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1268830 { margin-bottom: 0; } #site-search-1268830 .site-search-form { padding: 0; } #site-search-1268830 #site-search-1268830-btn { outline: none; } #site-search-1268830 #site-search-1268830-term { border: 0; box-shadow: none; } #site-search-1268830 .site-search-form { box-shadow: none; } #tncms-block-1847742 .tnt-prop-img { max-width: 994px; } #site-logo-1847742 { color: #666; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"mobile_pattern","style":"default","path":"\/classof2020\/westada_school_district\/rocky_mountain_high_school","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"infinity_scroll":{"display":"summary","order":"latest"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":171},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"mobile_pattern","style":"default","path":"\/classof2020\/westada_school_district\/rocky_mountain_high_school","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"infinity_scroll":{"display":"summary","order":"latest"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":171},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PZ22872');})();</script>
<script src="//tags.crwdcntrl.net/c/9940/cc.js?ns=_cc9940" id="LOTCC_9940"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc9940.add('tp', 'TNNW');
		_cc9940.add('act', ' User Login');
		_cc9940.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc9940.bcp();
</script>

<script src="//s.ntv.io/serve/load.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["jason dodd","school","major","national honors society","future","jessica miceli","study","state university"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.36770bdfae09a8898776cd45ffd261f5.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.562ac43ab5c59b0f315e3f7aabdfac51.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/idahopress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.facebook.comments.89e3602c68154764e889947868c957c9.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.waypoints.1115c65bd62165d952fac7c1b6918b2a.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Dodd, Sienna | Rocky Mountain High School | idahopress.com</title>
            
    <style>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</style> <link rel="shortcut icon" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/ip-logo-btn.png?_dc=1527607132"> <style> /* Rules for premium icon */ .headline-list .premium-asset-icon { margin-left: 0; margin-right: 0; } /* * Election Tables */ .table-election thead { background: #444; border-color: #444; border-top: 1px solid #444; color: white; font-size: 10px; text-transform: uppercase; } .table-election thead tr, .table-election thead tr th { border-bottom: none; border-color: #444; } .table-election thead th:first-of-type { border-left: 5px solid #444; } .table-election thead th { font-weight: 400; border-color: #444 !important; } .table-election tbody td { border-color: #444; } .table-election .progress { margin-bottom: 0; } .table-election td.dem { border-left: 5px solid blue; } .table-election .progress-bar-dem { background-color: blue; } .table-election td.rep { border-left: 5px solid red; } .table-election .progress-bar-rep { background-color: red; } .table-election td.ind { border-left: 5px solid gray; } .table-election .progress-bar-ind { background-color: gray; } .table-election td.con { border-left: 5px solid #962dce; } .table-election .progress-bar-con { background-color: #962dce; } .table-election td.lib { border-left: 5px solid #e2cc1f; } .table-election .progress-bar-lib { background-color: #e2cc1f; } </style> <style> .navbar-toggle { float: left;} </style>
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/994970f0-78c2-11e8-9d68-c7a1ab005703.png?resize=180%2C180" />
    
        <link rel="amphtml" href="https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.amp.html" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//connect.facebook.net">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Dodd, Sienna | Rocky Mountain High School | idahopress.com" href="http://www.idahopress.com/search/?f=rss&amp;t=article&amp;c=classof2020/westada_school_district/rocky_mountain_high_school&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html" />
            
    <script defer src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
            <!-- page app is editorial url is /classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html--><!-- loading site js -->
        <!-- Global site tag (gtag.js) - AdWords: 804983089 -->
        <script async src="https://www.googletagmanager.com/gtag/js?id=AW-804983089"></script>
        <script>
          window.dataLayer = window.dataLayer || [];
          function gtag(){dataLayer.push(arguments);}
          gtag('js', new Date());
        
          gtag('config', 'AW-804983089');
        </script>
        <script>
          gtag('event', 'page_view', {
            'send_to': 'AW-804983089',
            'user_id': 'replace with value'
          });
        </script>

        
            




        </head>
        <body class="fixed-scroll-nav  blox-asset app-editorial uuid-71a472b8-d8d0-54e8-89c7-ada1cd62a75f  section-classof2020 section-westada-school-district section-rocky-mountain-high-school type-article infinity-summary" data-path="/classof2020/westada_school_district/rocky_mountain_high_school">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.idahopress.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=mobile_pattern&tncms.page.style=default&tncms.page.path=%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.infinity_scroll.display=summary&tncms.infinity_scroll.order=latest&tncms.vendor.outbrain=disabled&tncms.vendor.taboola=&tncms.system.render_time=171&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.asset.id=71a472b8-d8d0-54e8-89c7-ada1cd62a75f&tncms.asset.app=editorial&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PZ22872&tncms.template.version=3.155.0&tncms.page.grid=mobile_pattern&tncms.page.style=default&tncms.page.path=%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.infinity_scroll.display=summary&tncms.infinity_scroll.order=latest&tncms.vendor.outbrain=disabled&tncms.vendor.taboola=&tncms.system.render_time=171&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.asset.id=71a472b8-d8d0-54e8-89c7-ada1cd62a75f&tncms.asset.app=editorial&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container">
    
    

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left ">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1556588" class="tncms-block">
<div id="site-brand-mark-1556588" class="tncms-block site-brand-mark">
        <section class="block emphasis-h3">
            <div class="block">
                <a href="/"><img class="img-responsive" alt="Idaho Press" src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/ip-logo-btn.png?_dc=1527607132"></a></div>
        </section>
    </div>
    <div id="site-follow-us-1556588" class="tncms-block site-follow-us">
        <div class="default">
            <section class="block emphasis-h3">
                <ul class="list-inline">
                    <li><a class="btn btn-xs btn-link fb" href="https://www.facebook.com/Idaho.Press" target="_blank" title="Facebook"><span class="fab tnt-facebook-f"></span></a></li><li><a class="btn btn-xs btn-link fb" href="https://twitter.com/theIdahoPress" target="_blank" title="Twitter"><span class="fab tnt-twitter"></span></a></li><li><a class="btn btn-xs btn-link fb" href="https://www.linkedin.com/company/103648" target="_blank" title="Linkedin"><span class="fab tnt-linkedin-in"></span></a></li><li><a class="btn btn-xs btn-link fb" href="https://www.youtube.com/user/idahopresstribune" target="_blank" title="YouTube"><span class="fab tnt-youtube"></span></a></li><li><a class="btn btn-xs btn-link fb" href="https://www.pinterest.com/source/idahopress.com/" target="_blank" title="Pinterest"><span class="fab tnt-pinterest"></span></a></li></ul>
            </section>
        </div>
        <div class="clearfix"></div>
    </div></div><div id="tncms-block-1506245" class="tncms-block"><div id="user-controls-1506245" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.idahopress.com/users/signup/?referer_url=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.idahopress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.idahopress.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1506245').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.idahopress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.idahopress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.idahopress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1506245').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.idahopress.com/users/logout/" id="user-logout-form-1506245"><input type="hidden" name="referer_url" value="https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1506247" class="tncms-block"><div class="tncms-block site-nav-sections-header">
  <section class="block emphasis-h3"><div class="clearfix">
      <ul class="list-inline block-links pos-top"><li>
          <a class="" href="/subscriptions">
            <span style="color:#ff9900;">Subscriptions from $15.00/mo</span>
          </a>
        </li>
      </ul><div class="drawer-title">
        <div class="drawer-title-inner">
          <h3>Sections</h3>
        </div>
      </div>
    </div>
  </section></div></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/2cscoop/"  class="nav-link tnt-section-2cscoop">#2Cscoop</a>
                                </li><li>
                                    <a href="/news/local/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a href="/news/state/"  class="nav-link tnt-section-state-news">State news</a>
                                </li><li>
                                    <a href="/news/national/"  class="nav-link tnt-section-national-news">National News</a>
                                </li><li>
                                    <a href="/news/world/"  class="nav-link tnt-section-world-news">World News</a>
                                </li><li>
                                    <a href="/news/strange"  class="nav-link tnt-section-strange-news">Strange News</a>
                                </li><li>
                                    <a href="/elections/"  class="nav-link tnt-section-elections">Elections</a>
                                </li><li>
                                    <a href="/immigration"  class="nav-link tnt-section-immigration">Immigration</a>
                                </li><li>
                                    <a href="/multimedia/"  class="nav-link tnt-section-videos">Videos</a>
                                </li><li>
                                    <a href="/multimedia/photos/"  class="nav-link tnt-section-photo-gallery">Photo Gallery</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/highschool/"  class="nav-link tnt-section-high-school">High School</a>
                                </li><li>
                                    <a href="/blueturfsports/"  class="nav-link tnt-section-boise-state">Boise State</a>
                                </li><li>
                                    <a href="/sports/localpro/"  class="nav-link tnt-section-local-pro">Local Pro</a>
                                </li><li>
                                    <a href="/sports/colleges/"  class="nav-link tnt-section-idaho-colleges">Idaho Colleges</a>
                                </li><li>
                                    <a href="/sports/national/"  class="nav-link tnt-section-national-sports">National Sports</a>
                                </li><li>
                                    <a href="/sports/outdoors/"  class="nav-link tnt-section-outdoor-sports">Outdoor Sports</a>
                                </li><li>
                                    <a href="/blogs/sports/"  class="nav-link tnt-section-sports-blogs">Sports Blogs</a>
                                </li><li>
                                    <a href="/multimedia/photos/"  class="nav-link tnt-section-photo-gallery">Photo Gallery</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/opinion/conversation/"  class="nav-link tnt-section-the-conversation">The Conversation</a>
                                </li><li>
                                    <a href="/opinion/editors_notebook/"  class="nav-link tnt-section-editors-notebook">Editors Notebook</a>
                                </li><li>
                                    <a href="/opinion/editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a href="/opinion/cheers_and_jeers/"  class="nav-link tnt-section-cheers-jeers">Cheers & Jeers</a>
                                </li><li>
                                    <a href="/opinion/guest_opinion/"  class="nav-link tnt-section-guest-opinon">Guest Opinon</a>
                                </li><li>
                                    <a href="/opinion/columnists/"  class="nav-link tnt-section-columnists">Columnists</a>
                                </li><li>
                                    <a href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/a_e/"  class="nav-link tnt-section-arts-entertainment">Arts & Entertainment</a>
                                </li><li>
                                    <a href="/community/announcements"  class="nav-link tnt-section-announcements">Announcements</a>
                                </li><li>
                                    <a href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                                </li><li>
                                    <a href="/community/front_porch/"  class="nav-link tnt-section-front-porch">Front Porch</a>
                                </li><li>
                                    <a href="/heyipt/"  class="nav-link tnt-section-heyipt">#HeyIPT</a>
                                </li><li>
                                    <a href="/outdoors/"  class="nav-link tnt-section-outdoors">Outdoors</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obits/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div></div></div></div>
                
                <div id="tncms-region-mobile-nav-middle-left-region" class="tncms-region "><div id="tncms-block-1268830" class="tncms-block"><section id="block-1268830" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1268830" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1268830" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-sm form-control">
        <input id="site-search-1268830-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1268830-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1268830-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1268830').submit();
        return false;
    });

    $('#site-search-1268830').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1268830 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1268830 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1268830-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-1510435" class="tncms-block"><div class="tncms-region-nav" id="htmlHardcoded-region-nav-mobile-nav-left-middle">
	<div class="panel-group nav navbar-nav" id="mobile-nav-left-middle_menu" role="tablist">
		
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a aria-controls="mobile-nav-left-middle_menu-child-1" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-middle_menu-child-1" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/special_report/">Special Reports</a>
				</div>
			</div>
			<ul class="collapse nav navbar-nav" id="mobile-nav-left-middle_menu-child-1">
<li>
					<a href="/special_report/criminal_justice/">Criminal Justice</a>
				</li>
				<li>
					<a href="/special_report/rapekits/">Rape Kits</a>
				</li>
				<li>
					<a href="/special_report/domesticviolence/">Domestic Violence</a>
				</li>
				<li>
					<a href="/special_report/homeless/">Homeless</a>
				</li>
				<li>
					<a href="/special_report/publictransit/">Public Transit</a>
				</li>
				<li>
					<a href="/special_report/immigration/">Immigration</a>
				</li>
				<li>
					<a href="/special_report/salute/">Salute</a>
				</li>
			</ul>
</div>
    
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a aria-controls="mobile-nav-left-middle_menu-child-2" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-middle_menu-child-2" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/special_sections/">Special Sections</a>
				</div>
			</div>
			<ul class="collapse nav navbar-nav" id="mobile-nav-left-middle_menu-child-2">
<li>
					<a href="https://www.idahopress.com/cavalcade/">Cavalcade</a>
				</li>
				<li>
					<a href="">Explore</a>
				</li>
				<li>
					<a href="https://www.idahopress.com/101/">101 Things to Do</a>
				</li>
				<li>
					<a href="http://www.buyidaho.org/Directory" target="_blank">Buy Idaho Directory</a>
				</li>
				<li>
					<a href="https://www.idahopress.com/community/health/stampede-for-the-cure-racks-up-big-bucks/article_6584b0d0-ddc9-52e1-88aa-1c5569f777b9.html">Snake River Stampede</a>
				</li>
				<li>
					<a href="https://www.idahopress.com/sports/photos-caldwell-night-rodeo-goes-out-with-a-bang/article_0a095acb-2afa-558e-9cc0-f5ca89fb0123.html">Caldwell Night Rodeo</a>
				</li>
				<li>
					<a href="">Football Preview</a>
				</li>
				<li>
					<a href="http://www.nampa.com/list/" target="_blank">Nampa Chamber Directory</a>
				</li>
			</ul>
</div>

                <div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a href="/eedition/?utm_source=redesign&amp;utm_medium=web&amp;utm_campaign=2018&amp;utm_term=eedition&amp;utm_content=slidemenu"><span class="topbarLink"><i aria-hidden="true" class="fas tnt-newspaper"></i> Read the E-Edition</span></a>
				</div>
			</div>
		</div>
                <div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a href="/marketplace" target="_blank"><i aria-hidden="true" class="fas tnt-map-marker-alt"></i> Business Directory</a>
				</div>
			</div>
		</div>
    
	</div>
</div></div></div>
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "><div id="tncms-block-1510446" class="tncms-block"><div class="tncms-region-nav" id="htmlHardcoded-region-nav-mobile-nav-left-below">
	<div class="panel-group nav navbar-nav" id="mobile-nav-left-bottom_menu" role="tablist">
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a aria-controls="mobile-nav-left-bottom_menu-child-1" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-1" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/customerservice/"><i aria-hidden="true" class="fas tnt-cog"></i> Subscriber Services</a>
				</div>
			</div>
			<ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-1">
<li>
					<a href="/subscriptions/">Start A Subscription</a>
				</li>
				<li>
					<a href="http://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=IPT" target="_blank">Manage Your Subscription</a>
				</li>
				<li>
					<a href="http://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=IPT" target="_blank">Make A Payment</a>
				</li>
				<li>
					<a href="http://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=IPT" target="_blank">Stop Your Paper For Vacation</a>
				</li>
				<li>
					<a href="/site/forms/subscription_services/deliveryissue/">Report A Delivery Issue</a>
				</li>
				<li>
					<a href="/newsletter/signup/">Get our newsletters</a>
				</li>
			</ul>
</div>
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a aria-controls="mobile-nav-left-bottom_menu-child-2" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-2" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a><i aria-hidden="true" class="fas tnt-bullhorn"></i> Make An Announcement</a>
				</div>
			</div>
			<ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-2">
<li>
					<a href="/site/forms/announcements/anniversary/">Anniversary</a>
				</li>
				<li>
					<a href="/site/forms/announcements/birth/">Birthdays</a>
				</li>
				<li>
					<a href="/site/forms/announcements/engagement/">Engagement</a>
				</li>
				<li>
					<a href="/site/forms/announcements/wedding/">Wedding</a>
				</li>
			</ul>
</div>
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
					<a aria-controls="mobile-nav-left-bottom_menu-child-3" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-3" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/site/services"><i aria-hidden="true" class="fas tnt-cubes"></i> Site Services</a>
				</div>
			</div>
			<ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-3">
<li>
					<a href="/newsletter/signup/">Get our newsletters</a>
				</li>
				<li>
					<a href="/site/about/">About Us</a>
				</li>
				<li>
					<a href="/site/contact/">Contact Us</a>
				</li>
				<li>
					<a href="/site/advertising/">Advertising</a>
				</li>
				<li>
					<a href="https://classadz.vdata.com/Nampa/ClsSelectClass.aspx" target="_blank">Place A Classified Ad</a>
				</li>
				<li>
					<a href="https://portal.cityspark.com/EventEntry/EventEntry/IdahoPressTribune" target="_blank">Add A Calendar Event</a>
				</li>
				<li>
					<a href="/site/sponsorships/">Sponsorships</a>
				</li>
				<li>
					<a href="/site/nie">Newspapers In Education</a>
				</li>
				<li>
					<a href="/multimedia/">Multimedia</a>
				</li>
				<li>
					<a href="/multimedia/photos/">Photo Gallery</a>
				</li>
                                
				<li>
					<a href="/multimedia/podcasts/">Podcasts</a>
				</li>
			</ul>
</div>
		<div class="panel panel-default">
			<div class="panel-heading" role="tab">
				<div class="panel-title">
                                        <a href="http://nl.newsbank.com/sites/pngnp/"><span class="topbarLink"><i class="fas tnt-list-ul"></i> Browse the Archives</span></a>
				</div>
			</div>
		</div>
	</div>
</div></div></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    

    

    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle " data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar" style='margin: 0 auto 4px auto;'></span>
                            <span class="icon-bar" style='margin: 0 auto 4px auto;'></span>
                            <span class="icon-bar" style='margin: 0 auto;'></span>
                            <span class="visible-lg visible-md sr-only-show">Full Menu</span>
                        </button>
                        
                    
                    

                    
                        <div class="navbar-brand pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1847742" class="tncms-block"><div id="site-logo-1847742" class="site-logo-container text-left" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/3c90cfb6-917a-11ea-9dd0-b37d034d0036.png?resize=200%2C47" 
            srcset="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/3c90cfb6-917a-11ea-9dd0-b37d034d0036.png?resize=200%2C47 200w, https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/3c90cfb6-917a-11ea-9dd0-b37d034d0036.png?resize=300%2C70 300w, https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/3c90cfb6-917a-11ea-9dd0-b37d034d0036.png?resize=400%2C93 400w, https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/3c90cfb6-917a-11ea-9dd0-b37d034d0036.png?resize=540%2C126 540w, https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/3c90cfb6-917a-11ea-9dd0-b37d034d0036.png?resize=750%2C175 750w, https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/3c90cfb6-917a-11ea-9dd0-b37d034d0036.png 1200w"
            sizes="100vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"></div>
    </div></div><div id="tncms-block-1847741" class="tncms-block"><h2 class="mobile-heading hidden-lg hidden-md"><a href="/virtual_graduations/" style="color: rgba(165, 222, 241,.6) !important;">2020 Graduation</a></h2></div></div>
                            
                        </div>
                    

                                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link  tnt-section-submit-profile"  href="/classof2020/submit_profile/" >
                    <span class="nav-label">Submit Profile</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/classof2020/search/?q=%20&amp;c%5B%5D=classof2020/profiles&amp;sd=desc&amp;l=10&amp;nsa=eedition" >
                    <span class="nav-label">Search</span>
                </a></li></ul></div>
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link  tnt-section-rocky-mountain-high"   >
                    <span class="nav-label">Rocky Mountain High</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        </div>
        
            
                <script>
                    jQuery(document).ready(function($){
                        var sNavContainer = '#site-navbar-container';
                        var sBodyContainer = '#main-body-container';
                        var sNavHeight = $(sNavContainer).height();
                        var iUnfixPoint = 0;
                        if( __tnt.client.platform.ios ){
                            $(sNavContainer).addClass('affix-sticky');
                        } else {
                            $sNavScroll = false;
                            $(window).on('scroll mousewheel', function(){
                                if( !$sNavScroll ){
                                    $sNavScroll = true;
                                    setTimeout(function(){
                                        var iFixPoint = $(sNavContainer).offset().top;
                                        var iCurrPoint = $(this).scrollTop();
                                        if( iCurrPoint >= iFixPoint && iCurrPoint > iUnfixPoint ){
                                            if( !$(sNavContainer).hasClass('affix') ){ 
                                                iUnfixPoint = iFixPoint;
                                                $(sNavContainer).addClass('affix').removeClass('affix-top');
                                                $(sBodyContainer).css('margin-top', sNavHeight+'px'); 
                                            }
                                        } else {
                                            if( !$(sNavContainer).hasClass('affix-top') ){ 
                                                $(sNavContainer).removeClass('affix').addClass('affix-top');
                                                $(sBodyContainer).css('margin-top', 0);
                                            }
                                        }
                                        $sNavScroll = false;
                                    }, 25);
                                }
                            });
                        }
                    });
                </script>
            
        
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1268810" class="tncms-block"><section id="block-1268810" class="block emphasis-   " >
        <ol class="breadcrumb  " itemscope itemtype="https://schema.org/BreadcrumbList"><li itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/classof2020/" itemprop="item">
                        <span itemprop="name">Class of 2020</span>
                    </a>
                    <meta itemprop="position" content="2" />
                </li><li itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/classof2020/westada_school_district/" itemprop="item">
                        <span itemprop="name">West Ada School District</span>
                    </a>
                    <meta itemprop="position" content="3" />
                </li><li class="active" itemprop="itemListElement" itemscope
      itemtype="https://schema.org/ListItem">
                    <a href="/classof2020/westada_school_district/rocky_mountain_high_school/" itemprop="item">
                        <span itemprop="name">Rocky Mountain High School</span>
                    </a>
                    <meta itemprop="position" content="4" />
                </li></ol></section></div><div id="tncms-block-1848376" class="tncms-block"><style>
.blox-autolist a[title="Search"]{
display: none;
}
.blox-autolist a[title="Submit"]{
display: none;
}
.blox-autolist a[title="Submit Profile"]{
display: none;
}
.blox-autolist a[title="News"]{
display: none;
}
.blox-autolist a[title="Profiles"]{
display: none;
}
</style></div><div id="tncms-block-1848374" class="tncms-block"></div></div></div>
        </div><div class="modal fullscreen" id="photo-carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f" tabindex="-1" role="dialog" aria-labelledby="photo-carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-body">
                    <button type="button" class="close" data-dismiss="modal">
                        <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                        <span class="sr-only">Close</span>
                    </button>
                    
    <div id="carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal" class="card photo-carousel   has-ad-unit  subscriber-hide letterbox-style-blur">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal" class="carousel-inner"><div  class="item photo-f4c2a60b-1a56-5732-ad48-95d2635c6d61">
                            <div class="item-container">
				                <div data-track-object='{"title":"Dodd, Sienna","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-vertical"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/f/4c/f4c2a60b-1a56-5732-ad48-95d2635c6d61/5edbba24548c8.image.jpg?resize=1200%2C1600"
                    
                    alt="Dodd, Sienna"
                    class="img-responsive owl-first-image owl-lazy blur"
                    width="1247"
                    height="1663"
                    data-src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/f/4c/f4c2a60b-1a56-5732-ad48-95d2635c6d61/5edbba24548c8.image.jpg?resize=1200%2C1600" /><div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/f/4c/f4c2a60b-1a56-5732-ad48-95d2635c6d61/5edbba24548c8.image.jpg?resize=200%2C267"/>
         </div>
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal" data-target=".caption-inner-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Fimage_f4c2a60b-1a56-5732-ad48-95d2635c6d61.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/image_f4c2a60b-1a56-5732-ad48-95d2635c6d61.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f4c2a60b-1a56-5732-ad48-95d2635c6d61"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Dodd%2C%20Sienna&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Fimage_f4c2a60b-1a56-5732-ad48-95d2635c6d61.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/image_f4c2a60b-1a56-5732-ad48-95d2635c6d61.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f4c2a60b-1a56-5732-ad48-95d2635c6d61"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/image_f4c2a60b-1a56-5732-ad48-95d2635c6d61.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/image_f4c2a60b-1a56-5732-ad48-95d2635c6d61.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f4c2a60b-1a56-5732-ad48-95d2635c6d61"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/f4c2a60b-1a56-5732-ad48-95d2635c6d61" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f4c2a60b-1a56-5732-ad48-95d2635c6d61"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20Dodd%2C%20Sienna&body=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Fimage_f4c2a60b-1a56-5732-ad48-95d2635c6d61.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f4c2a60b-1a56-5732-ad48-95d2635c6d61"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/image_f4c2a60b-1a56-5732-ad48-95d2635c6d61.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f4c2a60b-1a56-5732-ad48-95d2635c6d61"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-f4c2a60b-1a56-5732-ad48-95d2635c6d61-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="f4c2a60b-1a56-5732-ad48-95d2635c6d61" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="f4c2a60b-1a56-5732-ad48-95d2635c6d61" class="save-list-f4c2a60b-1a56-5732-ad48-95d2635c6d61-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="f4c2a60b-1a56-5732-ad48-95d2635c6d61" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-c001fe9d-6d9c-5e5c-a726-8f8639e42497">
                            <div class="item-container">
				                <div data-track-object='{"title":"Dodd, Sienna","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-vertical"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/c/00/c001fe9d-6d9c-5e5c-a726-8f8639e42497/5edbba24cd134.image.jpg?resize=1200%2C1600"
                    
                    alt="Dodd, Sienna"
                    class="img-responsive owl-first-image owl-lazy blur"
                    width="1247"
                    height="1663"
                    data-src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/c/00/c001fe9d-6d9c-5e5c-a726-8f8639e42497/5edbba24cd134.image.jpg?resize=1200%2C1600" /><div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/c/00/c001fe9d-6d9c-5e5c-a726-8f8639e42497/5edbba24cd134.image.jpg?resize=200%2C267"/>
         </div>
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal" data-target=".caption-inner-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Fimage_c001fe9d-6d9c-5e5c-a726-8f8639e42497.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/image_c001fe9d-6d9c-5e5c-a726-8f8639e42497.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c001fe9d-6d9c-5e5c-a726-8f8639e42497"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Dodd%2C%20Sienna&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Fimage_c001fe9d-6d9c-5e5c-a726-8f8639e42497.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/image_c001fe9d-6d9c-5e5c-a726-8f8639e42497.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c001fe9d-6d9c-5e5c-a726-8f8639e42497"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/image_c001fe9d-6d9c-5e5c-a726-8f8639e42497.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/image_c001fe9d-6d9c-5e5c-a726-8f8639e42497.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c001fe9d-6d9c-5e5c-a726-8f8639e42497"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/c001fe9d-6d9c-5e5c-a726-8f8639e42497" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"c001fe9d-6d9c-5e5c-a726-8f8639e42497"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20Dodd%2C%20Sienna&body=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Fimage_c001fe9d-6d9c-5e5c-a726-8f8639e42497.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"c001fe9d-6d9c-5e5c-a726-8f8639e42497"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/image_c001fe9d-6d9c-5e5c-a726-8f8639e42497.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c001fe9d-6d9c-5e5c-a726-8f8639e42497"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-c001fe9d-6d9c-5e5c-a726-8f8639e42497-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="c001fe9d-6d9c-5e5c-a726-8f8639e42497" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="c001fe9d-6d9c-5e5c-a726-8f8639e42497" class="save-list-c001fe9d-6d9c-5e5c-a726-8f8639e42497-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="c001fe9d-6d9c-5e5c-a726-8f8639e42497" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </div>
    </div>
        <script>
            jQuery(document).ready(function($){
                $('#photo-carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f').on('show.bs.modal', function(e){
                    $('#fixed-leaderboard-top-container').addClass('overlay-leaderboard');
                });
                $('#photo-carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f').on('hide.bs.modal', function(e){
                    $('#fixed-leaderboard-top-container').removeClass('overlay-leaderboard');
                });
            });
        </script><article itemscope itemtype="https://schema.org/Article" id="asset-71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="asset article-default"  data-url="https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/f/4c/f4c2a60b-1a56-5732-ad48-95d2635c6d61/5edbba24548c8.image.jpg?crop=1247%2C1247%2C0%2C208&resize=630%2C630&order=crop%2Cresize">
            <meta itemprop="width" content="630">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="idahopress.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html" />
    <div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.idahopress.com\/tncms\/search\/mlt\/?origin=71a472b8-d8d0-54e8-89c7-ada1cd62a75f&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="asset-paging">
                <div id="paging-prev-71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="paging-link prev offset"></div>
                <div id="paging-next-71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Dodd, Sienna
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2020-06-06T00:00:00-06:00" class="tnt-date asset-date text-muted">
            Jun 6, 2020
        </time>
    </li>
            <li class="hidden-print"><time datetime="2020-06-06T00:00:00-06:00" class="tnt-date asset-date text-muted">
            Jun 6, 2020
        </time><span class="text-muted">Updated </span><time datetime="2020-06-06T12:25:09-06:00" class="tnt-date asset-date text-muted">9 min ago</time>
    </li>
        
        
            <li class="hidden-print"><a href="/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html#comments" class="cm"><span class="fas tnt-comments"></span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-06-06T00:00:00-06:00">
    <meta itemprop="datePublished" content="2020-06-06T00:00:00-06:00">
    <meta itemprop="dateModified" content="2020-06-06T06:25:09-06:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Dodd%2C%20Sienna&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20Dodd%2C%20Sienna&body=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-md-12"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div id="asset-photo-carousel">
    <div id="carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="card photo-carousel    subscriber-hide letterbox-style-blur">
            
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect hidden-print"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect hidden-print"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            
            <div id="gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="carousel-inner"><div  class="item photo-f4c2a60b-1a56-5732-ad48-95d2635c6d61">
                            <div class="item-container">
				                <div data-track-object='{"title":"Dodd, Sienna","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-vertical"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                            <a href="#1" data-photo-target=".photo-f4c2a60b-1a56-5732-ad48-95d2635c6d61" data-instance="#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal" data-target="#photo-carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1247">
            <meta itemprop="height" content="1663">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/f/4c/f4c2a60b-1a56-5732-ad48-95d2635c6d61/5edbba24548c8.image.jpg?resize=1200%2C1600">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/f/4c/f4c2a60b-1a56-5732-ad48-95d2635c6d61/5edbba24548c8.image.jpg?resize=1200%2C1600">
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/f/4c/f4c2a60b-1a56-5732-ad48-95d2635c6d61/5edbba24548c8.image.jpg?resize=1200%2C1600"
                    
                    alt="Dodd, Sienna"
                    class="img-responsive owl-first-image owl-lazy blur"
                    width="1247"
                    height="1663"
                    data-src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/f/4c/f4c2a60b-1a56-5732-ad48-95d2635c6d61/5edbba24548c8.image.jpg?resize=1200%2C1600" />
            </div><div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/f/4c/f4c2a60b-1a56-5732-ad48-95d2635c6d61/5edbba24548c8.image.jpg?resize=200%2C267"/>
         </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-71a472b8-d8d0-54e8-89c7-ada1cd62a75f collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div><div  class="item photo-c001fe9d-6d9c-5e5c-a726-8f8639e42497">
                            <div class="item-container">
				                <div data-track-object='{"title":"Dodd, Sienna","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-vertical"><div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                        
                                        
                                            <a href="#2" data-photo-target=".photo-c001fe9d-6d9c-5e5c-a726-8f8639e42497" data-instance="#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal" data-target="#photo-carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fas tnt-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1247">
            <meta itemprop="height" content="1663">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/c/00/c001fe9d-6d9c-5e5c-a726-8f8639e42497/5edbba24cd134.image.jpg?resize=1200%2C1600">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/c/00/c001fe9d-6d9c-5e5c-a726-8f8639e42497/5edbba24cd134.image.jpg?resize=1200%2C1600">
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/c/00/c001fe9d-6d9c-5e5c-a726-8f8639e42497/5edbba24cd134.image.jpg?resize=1200%2C1600"
                    
                    alt="Dodd, Sienna"
                    class="img-responsive owl-first-image owl-lazy blur"
                    width="1247"
                    height="1663"
                    data-src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/c/00/c001fe9d-6d9c-5e5c-a726-8f8639e42497/5edbba24cd134.image.jpg?resize=1200%2C1600" />
            </div><div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/assets/v3/editorial/c/00/c001fe9d-6d9c-5e5c-a726-8f8639e42497/5edbba24cd134.image.jpg?resize=200%2C267"/>
         </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-71a472b8-d8d0-54e8-89c7-ada1cd62a75f collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="71a472b8-d8d0-54e8-89c7-ada1cd62a75f" data-smart-adunit="/94837440/nampa/ipt/classof2020/westada_school_district/rocky_mountain_high_school">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                            
                            <div id="share-left-affix" class="share-container content-left hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Dodd%2C%20Sienna&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20Dodd%2C%20Sienna&body=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="71a472b8-d8d0-54e8-89c7-ada1cd62a75f" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="save-list-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="71a472b8-d8d0-54e8-89c7-ada1cd62a75f" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        
                        <div class="asset-body has-fixed-share" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above visible-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Dodd%2C%20Sienna&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20Dodd%2C%20Sienna&body=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="71a472b8-d8d0-54e8-89c7-ada1cd62a75f" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="save-list-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="71a472b8-d8d0-54e8-89c7-ada1cd62a75f" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p><strong>School:</strong> Rocky Mountain High School</p><p><strong>Future plans:</strong> Boise State University--Global Studies Major</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p><strong>Accomplishments:</strong> True Blue Scholarship</p>
     <!-- search-2020-04-02-secondstreet-signup --> 
    
    
    

<p><strong>Extracurriculars:</strong> National Honors Society</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p><strong>Parents' names:</strong> Jason Dodd and Jessica Miceli-Dodd</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    
        
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Dodd%2C%20Sienna&via=theidahopress&url=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahopress.com/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahopress.com/tncms/asset/editorial/71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20Press%5D%20Dodd%2C%20Sienna&body=https%3A%2F%2Fwww.idahopress.com%2Fclassof2020%2Fwestada_school_district%2Frocky_mountain_high_school%2Fdodd-sienna%2Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/classof2020/westada_school_district/rocky_mountain_high_school/dodd-sienna/article_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"71a472b8-d8d0-54e8-89c7-ada1cd62a75f"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="71a472b8-d8d0-54e8-89c7-ada1cd62a75f" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="71a472b8-d8d0-54e8-89c7-ada1cd62a75f" class="save-list-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="71a472b8-d8d0-54e8-89c7-ada1cd62a75f" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22jason%20dodd%22#tncms-source=keyword" class="tag-jason-dodd label label-default" data-tncms-track-dmp='search: jason-dodd'>Jason Dodd</a>
            </li> <li>
                <a href="/search/?k=%22school%22#tncms-source=keyword" class="tag-school label label-default" data-tncms-track-dmp='search: school'>School</a>
            </li> <li>
                <a href="/search/?k=%22major%22#tncms-source=keyword" class="tag-major label label-default" data-tncms-track-dmp='search: major'>Major</a>
            </li> <li>
                <a href="/search/?k=%22national%20honors%20society%22#tncms-source=keyword" class="tag-national-honors-society label label-default" data-tncms-track-dmp='search: national-honors-society'>National Honors Society</a>
            </li> <li>
                <a href="/search/?k=%22future%22#tncms-source=keyword" class="tag-future label label-default" data-tncms-track-dmp='search: future'>Future</a>
            </li> <li>
                <a href="/search/?k=%22jessica%20miceli%22#tncms-source=keyword" class="tag-jessica-miceli label label-default" data-tncms-track-dmp='search: jessica-miceli'>Jessica Miceli</a>
            </li> <li>
                <a href="/search/?k=%22study%22#tncms-source=keyword" class="tag-study label label-default" data-tncms-track-dmp='search: study'>Study</a>
            </li> <li>
                <a href="/search/?k=%22state%20university%22#tncms-source=keyword" class="tag-state-university label label-default" data-tncms-track-dmp='search: state-university'>State University</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print"><a id="comments-collapsible-toggle" class="btn btn-block btn-lg btn-default"><i class="fas tnt-sync"></i> Load comments</a><div id="comments-collapsible" class="comments-container-collapsible collapsed">
                
                <div id="comments-container" class="comments-container">
                    
                    <div
                        id="comments" 
                        class="fb-comments" 
                        data-href="http://www.idahopress.com/tncms/asset/editorial/71a472b8-d8d0-54e8-89c7-ada1cd62a75f/" 
                        data-num-posts="10" 
                        data-width="100%" 
                    ></div>
                    <style>
                        .fb_iframe_widget,
                        .fb_iframe_widget span,
                        .fb_iframe_widget span iframe[style]{
                            min-width:100%!important;
                            width:100%!important;
                        }
                    </style>
                </div>
            
        </div></div></div>
            </div>

            

            </div>
        </div></div>
</article><div id="infinite-container" class="infinity-summary-container hidden-print">
        <div id="infinite-more" data-next-url="https://www.idahopress.com/tncms/search/mlt/?origin=71a472b8-d8d0-54e8-89c7-ada1cd62a75f&app=editorial&inline=infinity&type=article%2Ccollection%2Cvideo%2Cyoutube">
            <i class="fas tnt-spinner tnt-pulse"></i>
        </div>
    </div>

    <script>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</script>
    
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1492197" class="tncms-block"><style>
	#tncms-block-1492197 {
		display: none;
		position: fixed;
		bottom: 0;
		z-index: 300;
		left: 50%;
		-webkit-transform: translateX(-50%);
		   -moz-transform: translateX(-50%);
			-ms-transform: translateX(-50%);
				transform: translateX(-50%);
		width: 100%;
		max-width: 900px;
	}
	#block-1492197 .block-title  {
		display: none;
	}
	.clearFix {
		clear: both;
	}
	.fop_promo {

	}
	.fop_heading {
		background-color: #72271d;
		color: #ffffff;
		padding: 12px 24px;
		font-size: 16px;
		line-height: 24px;
		position: relative;
	}
	.fop_offerShort {
		float: left;
		padding-right: 24px;
	}
	.fop_login {
		float: right;
		padding-right: 36px;
		font-size: 14px;
	}
	.fop_login a {
		color: #ffffff;
		text-decoration: none;
	}
	.fop_login a:hover {
		color: #ffffff;
		text-decoration: underline;
	}
	.fop_close {
		position: absolute;
		top: 12px;
		right: 12px;
		width: 24px;
		height: 24px;
		text-align: center;
		font-size: 16px;
		cursor: pointer;
	}
	.fop_body {
		background-color: #f0f0f0;
		color: #222222;
		border-left: 1px solid rgba(0,0,0,0.25);
		border-right: 1px solid rgba(0,0,0,0.25);
		max-height: 0;
		-webkit-transition: all 300ms ease;
		transition: all 300ms ease;
	}
	#block-1492197:hover .fop_body {
		max-height: 1000px;
		border-bottom: 1px solid rgba(0,0,0,0.25);
	}
	.fop_body > div {
		display: inline-block;
		width: 33.333%;
		vertical-align: middle;
		padding: 24px 24px;
	}
	.fop_logo {
		text-align: center;
	}
	.fop_logo img {
		margin: 0 auto;
	}
	.fop_tagline {
		text-align: center;
		font-size: 16px;
		line-height: 24px;
	}
	.fop_offerLong {
		text-align: center;
	}
	.fop_offerLong .fop_offerText {
		text-align: left;
		margin-bottom: 12px;
	}
	.fop_offerLong .fop_offerLink {
		margin: 0 auto;
		border: 1px solid #72271d;
		background-color: #72271d;
		color: #ffffff;
		display:inline-block;
		padding:6px 15px;
		cursor: pointer;
		-webkit-transition: all 200ms ease;
		transition: all 200ms ease;
	}
	.fop_offerLink:hover {
		background-color: #ffffff;
		color: #72271d;
		display:inline-block;
		padding:6px 15px;
		text-decoration: none;
	}
	.fop_offerLink:hover a {
		text-decoration: none;
	}
	@media screen and (max-width: 750px) {
		.fop_body > div {
			width: 100%;
			padding: 12px 24px;
		}
		.fop_body {
			padding: 0px 0px;
		}
		#block-1492197:hover .fop_body {
			padding: 12px 0px;
		}
		.fop_offerLong .fop_offerText {
			text-align: center;
		}
	}
</style>
<script>
(function($) {
$(function() {
	var thisBlock = $('#tncms-block-1492197');
	var thisBlockClose = $('#tncms-block-1492197 .fop_close');
	var urSet = $.cookie('tncms-services');
	var fopNo = $.cookie('fop_no');
	// user closed promo
	thisBlockClose.click(function(){
		thisBlock.css('display','none');
		$.cookie('fop_no', 1, { path: '/', expires: 7 });
	});
	// user is logged in or has previously closed promo
	if( ( urSet && urSet != '' ) || ( fopNo && fopNo != '' ) ) {
		thisBlock.css('display','none');
	} else {
		thisBlock.css('display','block');
	}
})
})(jQuery);
</script><section id="block-1492197" class="block emphasis- #222222 heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1492197 #ffffff">
        <div class="block-title-inner">
            <h2>
                
                Footer Offer Promo
                
            </h2>
        </div>
    </div></div><div class="fop_promo invalid-subscribers-only">
	<div class="fop_heading">
		<div class="fop_offerShort">Join now to get home delivery for as low as $10/month, any way you want it!</div>
		<div class="fop_login">Already a member? <a href="https://www.idahopress.com/users/login/">Login Here</a></div>
		<div class="fop_close"><i class="fas tnt-times" aria-hidden="true"></i></div>
		<div class="clearFix"></div>
	</div>
	<div class="fop_body">
		<div class="fop_logo"><img class="media-object img-responsive " src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/custom/image/2802b32e-641e-11e8-acee-4b19619b1320.png" alt=""></div><div class="fop_tagline">Local News Worth Holding
		</div><div class="fop_offerLong">
			<div class="fop_offerText">Sign up for a new subscription today and get home delivery or digital-only access for only $10/month!.</div>
			<a href="/subscriptions/" class="fop_offerLink">Join Today!</a>
		</div>
	</div>
</div></section></div><div id="tncms-block-1598809" class="tncms-block">
<div class="footerContainer-1598809 footerContainer footer-upper hidden-sm">
        <div class="cols-wrap">
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/" style="color:#fff;">News</a></li>
                <li class="col-item"><a href="/" title="Idaho Press">Idaho Press</a></li><li class="col-item"><a href="/kuna" title="Kuna Melba News">Kuna Melba News</a></li><li class="col-item"><a href="/meridian" title="Meridian Press">Meridian Press</a></li><li class="col-item"><a href="/emmett" title="Messenger-Index">Messenger-Index</a></li><li class="col-item"><a href="/blueturfsports" title="Blue Turf Sports">Blue Turf Sports</a></li><li class="col-item"><a href="/eyeonboise" title="Eye On Boise">Eye On Boise</a></li><li class="col-item"><a href="/boiseweekly" title="Boise Weekly">Boise Weekly</a></li><li class="col-item"><a href="http://www.postregister.com/farmandranch" target="_blank" title="Farm & Ranch">Farm & Ranch</a></li><li class="col-item"><a href="/eedition/" target="" title="E-Edition">E-Edition</a></li><li class="col-item"><a href="/classifieds/" target="" title="Classifieds">Classifieds</a></li><li class="col-item"><a href="/obituaries/" target="" title="Obituaries">Obituaries</a></li><li class="col-item"><a href="/subscriptions/" target="" title="Subscribe Today">Subscribe Today</a></li></ul>
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/site/services/" style="color:#fff;">Services</a></li><li class="col-item"><a href="/site/advertising" target="" title="Advertising">Advertising</a></li><li class="col-item"><a href="/site/nie" target="" title="Newspapers In Education">Newspapers In Education</a></li><li class="col-item"><a href="https://classadz.vdata.com/NampaIdahoPressTribune/Advertising/Advertiser" target="_blank" title="Place a Classified Ad">Place a Classified Ad</a></li><li class="col-item"><a href="https://portal.cityspark.com/EventEntry/EventEntry/IdahoPressTribune" target="_blank" title="Add a Calendar Event">Add a Calendar Event</a></li><li class="col-item"><a href="/site/forms/subscription_services/deliveryissue/delivery_issues/" target="" title="Report Delivery Issue">Report Delivery Issue</a></li><li class="col-item"><a href="https://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=IPT" target="_blank" title="Manage Your Subscription">Manage Your Subscription</a></li><li class="col-item"><a href="https://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=IPT" target="_blank" title="Pay Subscription Bill">Pay Subscription Bill</a></li><li class="col-item"><a href="https://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=IPT" target="_blank" title="Vacation Stop">Vacation Stop</a></li><li class="col-item"><a href="/site/activate" target="" title="Activate Your Online Account">Activate Your Online Account</a></li><li class="col-item"><a href="https://www.idahopress.com/stimulus/" target="" title="Stimulus">Stimulus</a></li></ul>
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/site/forms/online_services/submit_news/" style="color:#fff;">Submissions</a></li><li class="col-item"><a href="/site/forms/online_services/submit_news" target="" title="Submit News">Submit News</a></li><li class="col-item"><a href="mailto:legals@idahopress.com" target="" title="Submit Legal Notices to legals@idahopress.com or call 208-465-8129">Submit Legal Notices to legals@idahopress.com or call 208-465-8129</a></li><li class="col-item"><a href="/site/forms/online_services/submit_sports" target="" title="Report Sports Scores/Stats">Report Sports Scores/Stats</a></li><li class="col-item"><a href="/site/forms/online_services/submit_cheer" target="" title="Submit a Cheers &amp; Jeers">Submit a Cheers &amp; Jeers</a></li><li class="col-item"><a href="/site/forms/online_services/letter" target="" title="Send a Letter to the Editor">Send a Letter to the Editor</a></li><li class="col-item"><a href="/site/forms/online_services/guest_opinion" target="" title="Submit a Guest Opinion">Submit a Guest Opinion</a></li><li class="col-item"><a href="http://selfserve.idahopress.com/" target="" title="Submit an Obituary">Submit an Obituary</a></li><li class="col-item"><a href="/site/forms/announcements/anniversary/" target="" title="Anniversary Announcement">Anniversary Announcement</a></li><li class="col-item"><a href="/site/forms/announcements/birth/" target="" title="Birthday Announcement">Birthday Announcement</a></li><li class="col-item"><a href="/site/forms/announcements/engagement/" target="" title="Engagement Announcement">Engagement Announcement</a></li><li class="col-item"><a href="/site/forms/announcements/wedding/" target="" title="Wedding Announcement">Wedding Announcement</a></li><li class="col-item"><a href="/site/forms/online_services/webissue/" target="" title="Website Issues">Website Issues</a></li></ul>
            <div class="footer-col footer-col-info col-md-3 col-sm-6 col-xs-12">
                <div class="footer-col-info-basic">
                    <div class="col-heading"><a href="/site/contact/" style="color:#fff;">Contact Us</a></div>
                    
                    <div class="col-item col-item-highlight">Idaho Press</div>
                    <div class="col-item"><a href="http://maps.google.com/maps?daddr=1618+N+Midland+Blvd+Nampa,+ID+83651" target="_blank">1618 N Midland Blvd<br>Nampa, ID 83651</a></div>
                    <div class="col-item"><a href="tel:2084679251">208-467-9251</a></div>
                    <div class="col-item"><a href="mailto:newsroom@idahopress.com">newsroom@idahopress.com</a></div><li class="col-item"><a href="/site/contact" target="" title="Contact Us">Contact Us</a></li><li class="col-item"><a href="/site/about" target="" title="About Us">About Us</a></li><li class="col-item"><a href="/site/staff" target="" title="Staff">Staff</a></li></div>
                <div class="footer-col-info-social">
                    <div class="col-heading">Follow Us</div><div class="col-item-icon"><a href="https://www.facebook.com/Idaho.Press" target="_blank" title="Facebook"><span class="fab tnt-facebook-f"></span></a></div><div class="col-item-icon"><a href="https://twitter.com/theIdahoPress" target="_blank" title="Twitter"><span class="fab tnt-twitter"></span></a></div><div class="col-item-icon"><a href="https://www.linkedin.com/company/103648" target="_blank" title="Linkedin"><span class="fab tnt-linkedin-in"></span></a></div><div class="col-item-icon"><a href="https://www.youtube.com/user/idahopresstribune" target="_blank" title="YouTube"><span class="fab tnt-youtube"></span></a></div><div class="col-item-icon"><a href="https://www.pinterest.com/source/idahopress.com/" target="_blank" title="Pinterest"><span class="fab tnt-pinterest"></span></a></div></div>
                <div class="footer-col-info-social" style="margin-top:15px;">
                    <li class="col-heading"><a href="/getthepaper/" style="color:#fff;">Get The Paper</a></li>
                    <div class="col-item"><a href="/getthepaper">Find the nearest store/rack location to pick up a copy.</a></div>
                </div>
            </div>
            <div style="clear:both;"></div>
        </div>
    </div></div><div id="tncms-block-1505608" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1505608">
        <div class="col-md-12"><small>&copy; Copyright 2020 <a href="/">Idaho Press</a>, 1618 N. Midland Blvd. Nampa, ID</small><small>&nbsp;| <a href="/site/terms.html">Terms&nbsp;of&nbsp;Service</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy&nbsp;Policy</a></small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in',
                                message = document.getElementById('blox-message-incompatible');

                            Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                el.style.display = 'block';
                            });
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                            }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            <div id="blox-message-incompatible" class="notification wall alert alert-dismissable alert-warning hidden-print" data-message="blox ad blocker">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <h4 class="clearfix meter-heading  media-heading row">
            Ads are being blocked by your browser.
        </h4>
        <p><strong>Please</strong> disable your ad blocker, whitelist our site, or <a class="alert-link" href="/subscriptions/?referer_url=https%253A%252F%252Fwww.idahopress.com%252Fclassof2020%252Fwestada_school_district%252Frocky_mountain_high_school%252Fdodd-sienna%252Farticle_71a472b8-d8d0-54e8-89c7-ada1cd62a75f.html">purchase a subscription</a></p>
    </div>
</template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("71a472b8-d8d0-54e8-89c7-ada1cd62a75f")});});
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                	_cc9940.add('act', dmpData);
	_cc9940.bcp();

            });
        });
    </script>
    
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/png_core/resources/scripts/png.js?_dc=1588962133"></script>
<script src="//os4m-d.openx.net/w/1.0/jstag?nc=94837440-PNG_Bidder"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/scripts/main.js?_dc=1565291251"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/scripts/jquery.matchHeight.js?_dc=1513711533"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/content/tncms/live/libraries/flex/components/site/resources/scripts/incognitoChecker.js?_dc=1517351390"></script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.66c591eb93f177b0f59892f361c3b1b4.js"></script>
<script>/*<![CDATA[*/ 
                jQuery(document).ready(function($) {
            
                var gallery_ad_71a472b8_d8d0_54e8_89c7_ada1cd62a75f_photo_modal = false;
                var gallery_changed_71a472b8_d8d0_54e8_89c7_ada1cd62a75f_photo_modal = false;
                var sUrl =  window.location.href,
                        sUuid = sUrl.split("_").pop(),
                        sId = sUuid.substring(0, sUuid.indexOf('.')),
                        aInlineImages = document.querySelectorAll('.inline-image .image, .inline-image .expand');
                     for (i = 0; i < aInlineImages.length; ++i) {
                        var oImage = aInlineImages[i],
                            sInstance = oImage.getAttribute('data-instance'),
                            sTarget = oImage.getAttribute('data-target');
                        if (!oImage.classList.contains("tnt-asset-presentation-infographic")) {
	                        if (sInstance != null && sTarget != null){
	                            if (!sInstance.includes(sId)){
	                                oImage.setAttribute('data-instance', '#gallery-items-' + sId + '-photo-modal');
	                            }
	                            if (!sTarget.includes(sId)){
	                                oImage.setAttribute('data-target', '#photo-carousel-' + sId);
	                            }
	                        }
                        }
                     }
                $('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal .owl-stage-outer").height( $('#carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        

                        
                            var currItem = $('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_71a472b8_d8d0_54e8_89c7_ada1cd62a75f_photo_modal = $('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal').data('owlCarousel');
                $('#carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_71a472b8_d8d0_54e8_89c7_ada1cd62a75f_photo_modal.prev();
                });
                $('#carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f-photo-modal .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_71a472b8_d8d0_54e8_89c7_ada1cd62a75f_photo_modal.next();
                });
            }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                // open photo modal
                jQuery(document).ready(function($){
                    $('[data-photo-target]').on('click', function(e){
                        e.preventDefault();
                        var item_target = $(this).data('target');
                        // get item index
                        var item_index = $(item_target +' '+$(this).data('photo-target')).parent().index();
                        // get current instance of carousel
                        var carousel_instance = $(this).data('instance');
                        var carousel_instance_data = $(carousel_instance).data('owlCarousel');
                        // fix non explict widths at viewports less than 900.
                        if(carousel_instance_data.width() < 320 & carousel_instance_data.viewport() < 900){
                            carousel_instance_data.onThrottledResize();
                        }
                        // load item from index
                        carousel_instance_data.to(item_index, 100, true);
                        // open modal
                        $(item_target).modal({'show':true});
                        __tnt.trackEvent({'category':'tnt-lightbox','action':'carousel-open', 'label':'article', 'value':'1'});
                        return false;
                    });
                    $('.photo-carousel-caption-toggle').on(__tnt.client.clickEvent, function(e){
                        var item_instance = $(this).data('instance');
                        $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon', $(item_instance +' .photo-carousel-caption-toggle').find('[data-fa-i2svg]').attr('data-icon') == 'minus-circle' ? 'plus-circle' : 'minus-circle');
                    });
                }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                jQuery(document).ready(function($) {
            
                var gallery_ad_71a472b8_d8d0_54e8_89c7_ada1cd62a75f = false;
                var gallery_changed_71a472b8_d8d0_54e8_89c7_ada1cd62a75f = false;
                var sUrl =  window.location.href,
                        sUuid = sUrl.split("_").pop(),
                        sId = sUuid.substring(0, sUuid.indexOf('.')),
                        aInlineImages = document.querySelectorAll('.inline-image .image, .inline-image .expand');
                     for (i = 0; i < aInlineImages.length; ++i) {
                        var oImage = aInlineImages[i],
                            sInstance = oImage.getAttribute('data-instance'),
                            sTarget = oImage.getAttribute('data-target');
                        if (!oImage.classList.contains("tnt-asset-presentation-infographic")) {
	                        if (sInstance != null && sTarget != null){
	                            if (!sInstance.includes(sId)){
	                                oImage.setAttribute('data-instance', '#gallery-items-' + sId + '-photo-modal');
	                            }
	                            if (!sTarget.includes(sId)){
	                                oImage.setAttribute('data-target', '#photo-carousel-' + sId);
	                            }
	                        }
                        }
                     }
                $('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f .owl-stage-outer").height( $('#carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        

                        
                            var currItem = $('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_71a472b8_d8d0_54e8_89c7_ada1cd62a75f = $('#gallery-items-71a472b8-d8d0-54e8-89c7-ada1cd62a75f').data('owlCarousel');
                $('#carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_71a472b8_d8d0_54e8_89c7_ada1cd62a75f.prev();
                });
                $('#carousel-71a472b8-d8d0-54e8-89c7-ada1cd62a75f .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_71a472b8_d8d0_54e8_89c7_ada1cd62a75f.next();
                });
            }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/idahopress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.5dd2f631c0899403c746c644466933ea.js"></script>
<script>/*<![CDATA[*/ $("#comments-collapsible-toggle").click(function() { $("#comments-collapsible, #comments-collapsible-toggle").toggleClass("collapsed"); }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            	_cc9940.add('act', serviceData);
	_cc9940.bcp();

                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        	_cc9940.add('act', dmpData);
	_cc9940.bcp();

                    }
                }
            }
         /*]]>*/</script></body>
</html>